/zed2i/zed_node/set_pose: Service call not valid: GNSS fusion is enabled.


I am using the zed-ros2-wrapper for the ZED2i camera in ROS2 Foxy on a Jetson AGX Xavier. When I attempt to call the /zed2i/zed_node/set_pose service, I encounter the error message “Service call not valid: GNSS fusion is enabled,” even though I am certain that GNSS fusion is disabled.

Testing as shown in the figure below:

I would appreciate a response as this issue is causing me significant inconvenience.

Thank you.

Hi @Ming
I just tested and validated the bug.

A fix will be provided as soon as possible

Thank you. Looking forward to your response!

The bug has been fixed. The fix will be automatically merged into the master branch as soon as the CI pipeline is completed.

Thank you very much!

Hi @Myzhar Please excuse me for making another inquiry here.

I often receive the following warning during launch:

“[zed_wrapper-2] [2023-03-27 18:56:18 UTC][ZED][WARNING] [Init] Requested depth_minimum_distance: 0.3 meters is too close, clamped to 1.5000001 meters.”

This results in my depth minimum being set to 1.5 meters, which is not what I desire. This occurs frequently.

I look forward to your response and appreciate your help.

This seems a ZED SDK bug. I report it to the team.

What SDK version are you using?

The SDK version I am using is 4.0.7 on Jetson AGX Xavier.

Hi @Myzhar
Where can I track whether this issue has been resolved?


The issue was solved a few hours after your report: Fix `set_pose` service call and Github deploy · stereolabs/zed-ros2-wrapper@b3ab2dd · GitHub

I recommend you subscribe to the GitHub repository to obtain notifications as soon as a new version is available by clicking on Watch and Star

@Myzhar Oh, sorry about the set_pose problem. I have solved it from the latest repository of github. Thank you very much.
What I am referring to here is the problem that depth_minimum_distance cannot be set normally during startup.
I want to know as soon as possible if there is any solution.

This is an SDK problem. Can you install the ZED SDK v4.0.8 released yesterday and verify if the problem persists?

OK I will try, I just need to download v4.0.8 and execute the installer, It will be updated directly from v4.0.7, right?
Will it affect the original things?


@Ming you can simply run the installer, it will handle everything with no issues.

Hi @Myzhar ,
Why does my ros_wrapper still show 4.0.7 after I installed v4.0.8?

[zed_wrapper-2] [INFO] [1699954564.681889117] [zed2i.zed_node]: ZED SDK Version: 4.0.7 - Build 78516_cbe54973

It is conceivable that depth_minimum_distance is not resolved
I use ZED_explorer and the lower right corner shows v4.0.8

Hi @Ming
did you clean the ROS workspace cache after installing the SDK?

okay, it can read v4.0.8!

Unfortunately, the depth_minimum_distance problem still exists.

OK, I issued a bug report for the SDK team

Thanks, Where can I track whether this depth_minimum_distance issue has been resolved?
This problem bothers me so much that I can’t use it normally :smiling_face_with_tear:


We have no public bug trackers. You can find the fix in the next SDK release, so follow the SDK download page for updates.