Hello. I’m trying to run Zed examples on Linux. This is the output I get when I run

I’m not sure what is the red error is for. This is the result I get when I want to run an example

cuda 11.4
zed sdk 4 0
python 3.8

The red error was fixed by installing onnx with pip. But as seen in the second image, it still gives me the same error when trying to run a project.

Hi, this is a mismatch between python api and SDK version. Sorry for that. This happens because the API changed between patches on 4.0, during the early access. Please install the latest SDK version (4.0.7) and the latest API, that will solve your issue.

Thank you alassagne, I will try and let you know.

Hi alassagne,
I installed 4.07 that seems like solved the problem but when i tried to run body tracking sample on github

I got this error


It seems you are struggling to open an OpenGL context. Do you have a display connected to the machine ? This particular sample will not work remotely.
I assume you are using a jetson and a ZED X ? What happens when you run tutorials ?

Yes we have monitor connected to our zedbox. and zedx camera. This is the result when i tried to run tutorials


It seems our python tutorial has an issue. Probably this comes from the latest cython version, int and bool cannot be mixed anymore.
To solve it, in the tutorial you can replace True with 1 (line 35)

I can upgrade the python version if that can solve the problems

It’s not the issue. The issue is on our side. you can just replace the line I said,
init_params.sdk_verbose = True
init_params.sdk_verbose = 1

Tried this too but another error came up

This happens because this tutorial was originally intended for ZED 2i and the resolution is incompatible.
Can you try to replace the line
init_params.camera_resolution = sl.RESOLUTION.HD1080
init_params.camera_resolution = sl.RESOLUTION.AUTO

This worked for tutorial but still i cant open other projects like body tracking python project on github

I think the problem here about the FBConfig with necessary capabilities not found in function fgOpenWindow part. I tried this article but I already get OpenGL vendor string: NVIDIA Corporation.

This article is relevant if you use a laptop.
For you, I’d advise to run

sudo apt install --reinstall nvidia-jetpack

I tried this too but didnt worked for me.

What did it output ?

installed without an error but still projects giving me FBConfig with necessary capabilities not found in function fgOpenWindow

I’m afraid you might find easier to reinstall your system. What kind of box do you have ?

I’m using zedbox. Can i find the solution with reinstalling opengl ?