Pyzed import error, undefined symbol

I got some problems like in [ errors]( errors, second image) and comments,
which My SDK version(4.0.5) doesn’t compatible with Python API(Pyzed).
(Basically Python samples worked nicely with ZED Box Orin Nx at first time, but after I installed Python-API in here,
the python-api like ‘’ brought error (ImportError…, undefined symbol …)

So as community indicates, I tried to update ZED SDK, downloaded ZED SDK for JetPack 5.1.1 (L4T 35.4) 4.0 and run it but it comes out same error.
(Is it the latest ZED SDK? the ‘apt-cache policy nvidia-jetpack’ command gets 5.1.1)

Because I’m the beginner of Linux, detail directions to install clean ZED SDK and python API would be helpful.

ZED Box Orin NX 16GB w/ ZED X mini cam
OS Ubuntu 20.04.6
ZED SDK 4.0.5
CUDA 11.4.315
python 3.8.10

Thank you in advance!

Sorry for all.
It works when I re-downloaded ZED SDK for JEtPack 5.1.1 and installed all the options with ‘Y’
(when I had installed before, I denied some options because I don’t need AI recognition)
And I recommend that try to launch python file before installing ZED Python API.

But I’m still wondering that the ZED SDK for JetPack 5.1.1 is the latest one and updating the Jetpack version