ZedX Driver (Argus Error)


After keeping the camera node up and running over few days, I get this error consistently every 2 to 3 days until I reset.
Currently on the master branch, Jetpack 5.1.2, with latest ZedX driver.

@anath93 does this happen while the node is running?
Have you tried to run the command sudo service nvargus-daemon restart and then restart the node to recover it?

@Myzhar Yes when the node is running for over 3 days continuously and also subscribed to topics or no topics. Usually a clean stop and start of ros2 launch starts the node again, dont have to restart the argus driver.

In that case, we can add a recovery feature in the node.
Can you open a “feature request” issue on GitHub with a full description of the error and the behavior?

Sure I will open the ticket.

1 Like

@Myzhar I can create a new topic, but this could be relatively short and quick, I tried installing this morning 4.0.8 sdk upgrading from 4.0.7 and it does not look the changes have overlaid on previous version. Few months ago, I had tried removing /usr/local/zed and upgrading again and I remember that I had to re-flash the jetson. Is there any other way to do this ?

When you install the ZED SDK the new installer automatically removes the old version.
Regarding ROS you must be sure to clean the CMake cache of your workspace otherwise the compiler will not rebuild the already-built nodes.

ROS 2:

cd <ros2_ws>
rm -rf build install log

then you can recompile the nodes:
colcon build --symlink-install --cmake-args=-DCMAKE_BUILD_TYPE=Release --executor parallel --parallel-workers $(nproc)

1 Like