Zed360 doesn't work

I have two Zed2i’s connected via USB, on a Windows 10 PC. Zed360 detects the cameras. However when I press “Setup the Room” I get a blank dialog and the application stops responding and must be force quit. I let it go for about 10 minutes to see if it would start responding again but it never did:

The Python API is having no problems using the two cameras. Unity is also having no problems using the two cameras. Zed Explorer can see and access both cameras.

I did have Zed 360 working a couple of times initially, it just suddenly stopped working and showing this behavior a few hours ago.

I tried rebooting the cameras and rebooting the PC, but it didn’t help.

How can I use Zed 360? How can I see what the problem is?


Ok; two things I noticed:

It works if I’m using a Zed2i + a Zed Mini; but it doesn’t work if I’m using two Zed2is.

The Python multicamera example with two Zed2is works if I’m using VGA resolution, but anything higher and it says “CAMERA NOT DETECTED” for one of the cameras after displaying both serial numbers.

I don’t know what this means, though.


Are you on a laptop?
Can you try switching around the USB ports? It may be a bandwidth issue if higher resolutions bring issues.
Do both ZED 2i work with the zed mini individually?

I am on a laptop.

I tried every combination of the 3 USB ports on the laptop with no change.

Both ZED 2i’s work with the Mini individually; it’s only the combo of the two ZED 2i’s that seems to be causing a problem. When both ZED 2i’s are plugged in I can use them one at a time (e.g. through ZED Explorer) but not both together (when the resolution is higher than VGA).

I am also suspecting a bandwidth issue. I have a couple of ZEDboxes laying around I might try to get a network streaming setup working instead of USB.

Are all the USB ports 3.0?

Also, are they on the same side of the laptop? These often have a common bridge to the motherboard, bringing bandwidth issues.

But I don’t understand why it would work with the ZED-M if that’s the case.
Is it always the same camera that fails to open? Can you try switching the cables around maybe?

I think it was a USB power problem.

I switched to using a powered hub for the cameras and everything seems to be working smoothly now, I was even able to get 3 cameras to work at the same time.

1 Like