Zed mini IMU_fuision not working properly


Hello Dear Community.
I am using zed mini camera for the first time so I do not know what’s happening.
I want to obtain visual inertia odometry data. I was using before the realsense T265 but it’s broke now so I changed to zed mini.
After installing the latest SDK and install the ROS package, when I run the lunch file zed_wrapper zedm.launch but I get this message infinite times Positional tracking -> Searching for a known position [SEARCHING]
Then if I echo this topic i can see the position and orientation but the position is giving me wrong values.

What could be the cause of this problem?

Steps to Reproduce

  1. Install ROS melodic
    2.Install latest SDK 3.7
    3.Install zed_wrapper package
  2. Run the launch file roslaunch zed_wrapper zedm.launch

Expected Result

Obtain position and orientation values

Actual Result

wrong values for position and orientation.
message Positional tracking -> Searching for a known position [SEARCHING]

ZED Camera model

ZED Mini


OS: Ubuntu 18.04
ROS: Melodic
SDK: 3.7

Anything else?

If I change the parameter imu_fusion: to false, I can get better values but it seems is not using its IMU.

Hi @DiegoHerrera1890
you already opened an issue on Github for this problem, please do not cross-post.

Can you try if the Positional Tracking example works as expected?

Hi dear @Myzhar
Thank you so much for your answer. Sorry for posting this issue into github.

I have tried the positional_tracking.py and is showing the same error [Searching] and [OK] repetitively and it is not moving accordingly with the movement of the zed camera in real world.

@DiegoHerrera1890 this is indeed an unusual bahavior.

Can you start the ZED_Sensor_Viewer tool to see if the inertial sensors are correctly sending the measurements?

@Myzhar I have started ZED_Sensor_viewer tool and we can still observe a wrong behaivor.

Processing: 20220906_124114-ZED-M-sn_15320254-ZEDSensorsData.csv…

It seems that the IMU is not working properly…

This seems indeed a not correct behavior of the IMU.
Can you try to perform a re-calibration of the IMU by using the command ZED_Calibration --calib_imu?

Let me know if this solves the issue, otherwise you must write to support@stereolabs.com to report the issue.

Thanks a lot @Myzhar the problem is solved.

1 Like