Zed depth viewer black stripe

Hey Stereolabs team,

doing some tests on Unity with the depth texture ZED2i generates, I noticed some weird behaviour in the left part of the camera, which I thought was due to the camera orientation in the room I was using it, but doing some tests today I saw that it’s something that always appear no matter what.



I’ve checked different angles, resolutions and Depth modes and all of them seems to have that black stripe. In neural mode it’s thinner but it’s still in there.

As you can see in the video attached in this post, looks like something that have been happening since I started using the camera.

The lens are clean and there is no visible damage on them.

I’ve attached the ZED Diagnostic file.

Cheers

ZED_Depth_black_stripe.json (20.3 KB)

Hi there @R2R0

This stripe is an artifact due to using stereo vision. This is the left depth view, meaning pixels from the left image to which are attached the depth computed from both left and right image. Thus, a small portion at the left of the image, where there is no overlap and thus no stereo matching between the left and right view, is not visible.
The “noise” is probably due to a low confidence on the edges (especially possible with the low luminosity), or the ULTRA mode not successfully stereo-matching.

The neural modes fill the depth map using AI, so the border is clean and sharp, and the thin strip is just the lack of overlap.

You can obtain a similar result with ULTRA by enabling the fill mode in the settings.

Hey @JPlou! :slightly_smiling_face:

I’m getting similar results using Neural mode in Unity.

In the video you can see the Depth Texture from the ZED_Rig_Mono->Camera_Left, and in the bottom custom shaders that get the depth texture from ZEDRenderingPlane->Depth and only display the elements between two ranges (1.37m and 1.47m in this very case).

The depth mode is set to Neural, and it’s capturing at HD1080 at 30FPS.

This kind of noise its really annoying, as I need to capture a small item (a ball that hits some targets in a wall), and if the targets are close to this, the game thinks the ball hit them.

Neural is the depth mode that give us the best results so far, as we saw with your help in this post two months ago https://community.stereolabs.com/t/depth-noise-on-zed2i/4861/9

Is there something else we can do to fix this?

Cheers!

It’s difficult to give advice without seeing the environment in question.

It could be the lighting or occlusions in your setup, or the contrast or gain.
In your first screenshots for instance it seems to have difficulties stereomatching the shelf area that is mostly black.

A workaround could be to use a ROI mask, excluding the uncertain areas.

Please send us an SVO to support@stereolabs.com referencing this post, replicating this setup, it will be way easier to investigate on our side.

Sure thing @JPlou!

I’ll send the SVO and some pictures so you can see everything correctly :man_bowing:

Thanks!

1 Like