/usr/bin/ld: warning: libsl_zed.so, needed by /usr/local/lib/librtabmap_core.so.0.21.1, not found (try using -rpath or -rpath-link)

I am building in jetson nano, ROS Melodic. Facing this warning while catkin_make rtabmap_ros pkg, which leads to undefined references to many sl::(parameters). can someone pls help me in this regard?

Hi @thiru
Welcome to the Stereolabs community.
Did you install the ZED SDK? What is the version required by RTABmap?


Are you using the first Jetson Nano or the new Jetson Orin Nano?
I advise you to ask also on the RTABmap forum because this seems more a problem related to RTABmap than the ZED SDK.

Am using the old Jetson nano. I will check from my side and update for a solution to this.

Solved this! Booted the nano with a new SD Card.
(ROS melodic installed)

  1. Install RTabMap first and catkin_make.
  2. Install zed wrappers and ZED examples second, in the same workspace and catkin_make.

i have done this reversed which caused the error.

Now, it is solved by following the above sequence for installation.

But still 3D mapping is not loading, which will be solved from rtabap issuses with nano.

Thanks !

1 Like