SVGA Resolution not working on Zed X with ZED depth viewer or with python samples

I tried both recording and the Depth Viewer. While I have no problems with HD1080 and HD1200 as soon as i turn to SVGA i get no image.
I uploaded two images of the depth viewer for reference(Hd1200 working and SVGA not).

SVGA though works if I use the ZED_Explorer.

Hi @Prospecto
I just tried to replicate your issue, and I couldn’t.
ZED X and ZED X Mini can work in every available combination of resolution and frame rate.

What GMSL2 capture card are you using?
What version of the ZED X Driver are you using?
What Jetson model?
What L4T version?

Hy @Myzhar. I am using a zed Box (orin 16gb) and L4T35.3_v4.1.1.

I found another problem in the ZED_Depth_Viewer.
Even on the working resolutions (e.g HD0180) when I use low quality depths I get flickering images.
Not so important since when I record by code the images are fine, BUT when I tried to switch to neural mode I received the message “neural mode not optimized yet”. This is actually very strange because:

  1. I used it yesterday
  2. In the resources the model is present (as expected since I optimized all the models)
    When I run the ZED_Diagnostic I get that all the models are not optimized.
    The only thing I changed is the power mode of the jetson orin (from 15W to 25W).

When trying to revert to 15W with “sudo nvpmodel -m 2” I get the following

NVPM ERROR: Error writing 252 to /sys/devices/gpu.0/tpc_pg_mask: 16
NVPM WARN: Reboot required for changing to this power mode: 2
NVPM WARN: DO YOU WANT TO REBOOT NOW? enter YES/yes to confirm:
NVPM ERROR: optMask is 1, no request for power mode

I used the same configuration as you and I could not replicate your problems.

Please record a video (screen capture) to show exactly what’s happening to understand better.

So, for what concerns the models not found it was due to the power mode.
Setting it back to sudo nvpmodel -m 2 and rebooting it found neural again.

Here I put the recording of my screen when using the depth viewer:
As you can see it flickers A LOT, sometimes it gets better (seems to me when the image is near, at the end of the recording you can see that the image is stable).

If I select depth mode neural it stops flickering.
In this second video I use depth mode neural (u can see no flickering) but after few seconds I pass to SVGA resolution and you can see I get no image at all

Hi @Prospecto
please provide more information concerning your setup.
A picture showing the system and all the connections would be useful.

It’s a ZED Box orin 16 GB with one zed x connected with the 4 to 1 gmsl cable (3 cables are free and one is linked to the ZED). I am using a screen with usb. Do you need any other information?

I don’t think it’s an issue related to cables because I can see flickering/ no flickering by changing the depth mode and keeping the camera still. Furthermore, even in performance mode if I bring something really close to the camera, (without moving the camera), the flickers stops. Finally, if I put the orin in MAXN power mode I don’t see any flickering even when I use the performance mode for depth computation.
My bet is that in some case the depth computation “crushes” and leads to flickering… could it be the case?

Anyway, my greatest concern is related to the lack of SVGA resolution which I haven’t explained yet.

Hi @Prospecto
do you face the same issues by using the ZED EXplorer tool?

No, with ZED Explorer I can use the SVGA resolution but with Zed Depth viewer, or even when I record the video with the following python sample, I get fully black/brown images (as shown in the video I uploaded before).

from display.generic_display import GenericDisplay
import as sl
from gnss_reader.gpsd_reader import GPSDReader
from exporter.gnss_saver import GNSSSaver, get_current_datetime
import exporter.KMLExporter as export
from signal import signal, SIGINT
import sys 

is_running = True 
#Handler to deal with CTRL+C properly
def handler(signal_received, frame):
    global is_running
    is_running = False 
signal(SIGINT, handler)

def main():
    global is_running
    # Open the camera
    zed = sl.Camera()
    init_params = sl.InitParameters()
    init_params.sdk_verbose = 1 
    init_params.camera_resolution = sl.RESOLUTION.SVGA #sl.RESOLUTION.HD1080 sl.RESOLUTION.HD1200 sl.RESOLUTION.SVGA
    init_params.camera_fps = 60 # 60,30,15
    status =
    if status != sl.ERROR_CODE.SUCCESS:
        print("[ZED][ERROR] Camera Open : "+repr(status)+". Exit program.")
    #Enable SVO recording :
    svo_path = "/home/user/Projects/Only_camera_acquisition.svo2"
    returned_state = zed.enable_recording(sl.RecordingParameters(svo_path,sl.SVO_COMPRESSION_MODE.H265) #H264_LOSSLESS
    if returned_state != sl.ERROR_CODE.SUCCESS:
        print("Recording ZED : "+repr(status)+". Exit program.")

    while is_running:
        # Grab camera:
        zed_status = zed.grab() #sl.ERROR_CODE.SUCCESS:    

if __name__ == '__main__':

Please share the recorded SVO with us, so we can test it.

SVGA_only_camera.svo2 (2.5 MB)
Here it is, I reduced the fps and did a really short video to stay in the 4MB limit

You can send me a longer SVO to

Hi @Prospecto
please write me an email to with a link to this thread.

I noticed something wrong with your camera calibration that must be checked by our optics team.

I’m having the exact same issues (both the issue with the bad image in SVGA mode and the flickering for other modes in the ZED Depth Viewer). In SVGA mode the images appear to change between blue/brown and change darker/lighter if I cover the cameras. No issues when viewing the images in SVGA mode in ZED Explorer.

Camera: Zed X Mini
Zed Box Orin NX 16GB
Jetpack version 5.1.1

Hi @Lepton.Ice.Tea welcome to the Stereolabs community

Please write me an email to with a short SVO recorded with ZED Explorer as an attachment.

While waiting for the support I tried even the zed mini X i bought and I am not getting the svga resolution as for the zed X.

When I use the SVGA resolution I noticed the following warning:

[2024-05-22 07:39:57 UTC][ZED][WARNING] Self Calibration Disabled.

I checked and init_camera.camera_disable_self_calib is correctly set to false.

Hi @Prospecto and @Lepton.Ice.Tea
can you please try to use the ZED Calibration tool (SDK v4.1.1) to recalibrate the camera and let me know if this fixes the issue?

We have identified an issue with ZED SDK versions 4.1.0 and 4.1.1 that prevents the correct use of SVGA resolutions. The SDK team is working to release ZED SDK version 4.1.2 soon, which will resolve this problem.

1 Like

I treid the calibration and actually SVGA is still broken even if I am able to see smth.
To revert back to previous calibration can I just substitute the old .conf file?
Except from svga can I expect that the other features are correctly working?

Furthermore, I would like to understand if I need to rerun the optimization of the models (e.g neural depth) for each jetson power mode.

Please read my update to my previous post:

If you need SVGA mode you can use the ZED SDK v4.0.8 until the v4.1.2 is released.