Streaming and corrupted frame chunks

Hey everyone. Whenever we try to use the ZED streaming examples we run into this problem of very bad stream performance, and ‘corrupted frame chunk received’ error messages. How to reproduce:

  • Have two machines on same local network (we have tried windows->windows, windows->linux, linux->linux, and linux->windows)

  • Run example code streaming sender and streaming receiver.

  • The sender correctly detects the receiver connecting

  • The receiver will sometimes see a very slow and delayed video feed. Mostly they see corrupted frame chunk error message. Stream often crashes.

This problem has followed us for a long time and across different hardware. Does anyone else have the same problem? Here is what we have tried to resolve it so far:

  • Streaming and receiving on the same computer
  • An array of different bitrate and frame chunk size options
  • Changing resolution and framerates
  • A lot of different networks
  • two different linux machines (including Jetson Xavier NX) and four different windows machines
  • Different ZED SDKs
  • Different CUDA versions
  • Replacing our ZED 2 camera

Thank you and hope to hear from someone with experience on this.

Did you try the ZED SDK 3.5.6 or 3.6 ?
A bug in streaming receiver has been fixed that made the streaming receiver crash on windows randomly.