Nvidia Jetson AGX Orin running ROS 2 with ZED 2

Hey guys
Here is a video showing the Nvidia Jetson AGX Orin running a ROS2 example using the ZED 2 camera
Beautiful !

Great job, thanks for sharing and for the nice words.

I’ve seen that you published another video last week:

Please do not hesitate to share your feedback about the ROS/ROS2 wrappers, the GStreamer plugins and all the other tests that you are going to make.

I purchased a ZED 2 camera mainly to run it with the Nvidia deepstream applications on the Jetson AGX Orin. Once I get that figured out I will share it with the community.

I had tried a Kinect for Azure but it was near impossible to work with.

I can tell just from the few examples I have ran with the ZED2 that you guys put a lot of thought and time into making the ZED cameras work with just about any application someone can think of.
Thanks

1 Like

I can’t run Zed2i on Jetson Orin. Any example I run, it gives me error:

CUDA erro at /builds/sl/ZEDKit/lib/src/sl_core/utils/util.cu:422 code=1(cudaErrorInvalidValue) “cudaCreateTextureObject(tex, &resDesc, &texDesc, Null)”

Only depth sensing and body tracking worked (/usr/local/zed/samples/).

zed_ros2_wrapper does not work either:
ros2 launch zed_display_rviz2 display_zed2i.launch.py
brings the rviz2 with Warnings: Invalid frame ID “map” passed to …

Hi @roboticsintelligence
what version of the ZED SDK are you using?
Please update to v3.7.6 if you are using an older version.

Jetson AGX Orin is a very recent board, with an operating system not yet stable, indeed thee Jetpack 5 is still in Developer Preview status.
The ZED SDK for AGX Orin is for this reason yet in Beta status, and it can happen that something does not work as expected. We can guarantee that we are working hard to solve all the issues as quickly as possible as happened in this case.

PS Please do not reply to a thread with “off-topic” issues. In this case, a post in a new thread with detailed information is always appreciated.

Hello Myzhar, I’m able to run the object detection example with ZED2 based on the yolov5 framework on Jetson Orin following building instructions described in the CPP version of Object Detection on custom dataset, and it works as expected. I’m Python developer and curious when the python build shall be expected.
In the meantime, how I can debug the CPP code execution during the runtime with the binary file located in the build directory? Are there any debug switches during the build time which enable debug data for debugger in the compiled executable file? Which debug tool is recommended for the community? I’m using Visual Code debugger for my python work needs.
Best regards,
Izidor

You can use the VSCode tools to correctly configure the IDE for debugging.
You can search for a guide on the internet because it all depends on the compiler and the OS that you are using.