Neural Depth mode on the Jetson Orin with the ROS wrapper?

How do I get the new neural depth mode working on the Jetson Orin with ZED 2i using the ZED ROS wrapper? I’m running ROS Noetic on Ubuntu 20.04 along with ZED SDK 3.7.4.

I’m facing some inconsistencies in depth output on reflective surfaces and/or outdoors when the sun is too bright. Depth quality is set to Ultra. I see that there is a new polarized filter option while purchasing the ZED 2i, but I would rather prefer if the neural depth mode improved these issues.

Hi @srijal97
Simply set depth quality to 4:

1 Like

That works, thank you!

1 Like