Muilt-Camera ROS2 Wrapper

For context here is the current setup I am using:

  • NVIDIA Jetson AGX Xavier
  • Ubuntu 18.04 LTS
  • Jetpack 4.6
  • ROS2 Eloquent
  • ZED SDK 3.6
  • Stereolabs ZED
  • Stereolabs ZED2i

I’d like to integrate the ZED ROS2 Wrapper with my two ZED cameras. When I try running the both launch files simultaneously, one of them fails to detect its respective camera. How might I go about modifying the ROS2 wrapper to work with a multi-camera setup?

Thanks :slight_smile:

Hi @austinlake04
if the two cameras are connected to the same host machine, then you must open them by using their serial number or idx, otherwise the ZED SDK always tries to open the camera with the lower idx:

Can you elaborate on this part? There is no “zed_id” defined in the existing launch files. Should I create a common.yaml for each of the cameras and write the id’s there or how should I go about it?

@rallpal Yes, that’s a solution.

However, we can add the zed_id and/or serial_number as parameters for the launch files.
Can you please add a feature request issue on Github to keep track of it?
It’s a quick modification…

Perfect, I got it to work, and posted a feature request on git.

1 Like

The launch files have been updated with the new zed_id and serial_number parameters

Hi, I am using this environment for multi-Camera launch file
Jetson Orin, Zed SDK 3.7, Zed-ros2-Examples (multi-Camera), 2 Zed Cameras.

I also use this command : ros2 launch zed_multi_camera cam_names:=‘[zed_right, zed_left]’ cam_models:=‘[zed, zed]’ cam_serials:=‘[21380,21148]’

However, it only opens either one of those cameras connected. I tried to run them separately using the zed.launch file and both of them works perfectly.

Hi @jheanelestrada
are you sure that the serial numbers that you are using are correct?
They do not see to match valid values

Yes. both are correct and running okay in my laptop but I tried the same (codes, same wrapper, same cameras) with jetson orin, it only choose either one of the camera to open.

I advise upgrading the ZED SDK and the ZED ROS2 Wrapper to the latest versions.
The ZED SDK v3.7 is an old version and we introduced a lot of improvements that can help you solve your problem.