Hi Stereolabs community,

I have 2 computers with ZED SDK 3.8.2 installed inside a Docker container: one laptop with Ubuntu 22.04 and one Jetson with L4T 35.1 (JetPack 5.0).

I would like to read the temperature from the camera using the Python API as follows:

>>> from pyzed import sl
>>> cam = sl.Camera()
>>> sensors_data = sl.SensorsData()
>>> cam.get_sensors_data(sensors_data, sl.TIME_REFERENCE.IMAGE)

When I get to the same point on the Jetson, the get_sensors_data method returns a MOTION SENSORS REQUIRED error.

Any idea what could cause this or how I can get around the problem?

In a separate thread I found that this could be caused by USB2/3 problems or a faulty cable. I am using the same camera and cable in both cases.

Kind regards

Hi, is it a ZED 2, ZED mini or ZED 2i ? the first generation of ZED does not have motion sensors.

If it’s a compatible ZED, indeed that must come from a faulty USB2 or cable. The video uses the USB3 while the IMU uses the USB2. If it’s a ZED 2, with a cable soldered to the ZED itself, it can also come from a severed connection. This is why ZED2i has a pluggable USB cable that can be changed more easily.

It is a ZED 2i camera.

I have tried 2 cameras and 2 different cables on both computers and get the same result.
It works on my laptop, but not on the Jetson.

What kind of jetson model is it ? Can you run ZED_Diagnostics and send the output ?

The IPC is an AVerMedia AG411B which contains a Jetson Xavier AGX module.

I had to send that IPC to a partner, but I installed everything in the same way on another device of the same model.
Here I had no problem reading out the temperature from the sensors (using the same ZED 2i camera and USB cable).

I was able to get hold of the ZED_Diagnostic results:
ZED_Diagnostic_Results.json (8.1 KB)

I believe these commands fixed the issue:

wget --no-check-certificate -O
bash --tar -x './99-slabs.rules'  > /dev/null 2>&1
sudo mv "./99-slabs.rules" "/etc/udev/rules.d/"
sudo chmod 777 "/etc/udev/rules.d/99-slabs.rules"
sudo udevadm control --reload-rules && sudo udevadm trigger