Issue with neural network using detectron2

Hi,

I am testing two famous machine learning packages with ZED2i, such as detectron2 and yolov7.
yolov7 model works pretty well without any issue. But I had an issue when I use detectron2.

I trained my custom model by detectron2 and tried to predict objects based on the ZED camera image using OpenCV. Simultaneously, I tried to display a 3D point cloud in the OpenGL viewer. Unfortunately, I faced the error below.

RuntimeError: CUDA error: invalid argument
CUDA kernel errors might be asynchronously reported at some other API call, so the stacktrace below might be incorrect.
For debugging consider passing CUDA_LAUNCH_BLOCKING=1.

This error was not shown when I passed my model through CPU. So, this error only occur when both ZED and Detectron use CUDA.

I was wondering if anyone succeed to integrate Detectron2 with ZED SDK.
Should I refer zed-pytorch (GitHub - stereolabs/zed-pytorch: 3D Object detection using the ZED and Pytorch)?
Any comments would be appreciated.

Thank you.

Best,
Jay

Hi @jlee
I think that this Github issue can contain useful information regarding your problem: