Huge drift with ZED2i

I just received my ZED2i, I ran the python demo relevant to tracking (positional_tracking.py) I noticed a huge drift on the Y axis (up and down) I tried enabling and disabling tracking parameters such as

  • tracking_parameters.enable_area_memory
  • tracking_parameters.enable_imu_fusion
    and most others, still when I lift the sensor, move around with it and place it back in its original location the drift is about 15-20cm although the movements I made are less than 1 meter.
    I am using
    -CUDA 11
    -SDK 3.5
    -REFERENCE_FRAME.WORLD
    -RESOLUTION.HD720 and HD1080

I used the Intel realsense T265 for a couple of years with acceptable results. I bought the ZED2i expecting much better results as the advertised translational drift is 0.3%
Your help is appreciated

Hi Mrassi,

I have had this problem as well with my Zed2 (not Zed2i), when we’ve travelled quite a distance (~100m), we would be out by tens of meters in the vertical direction.

It’s possible some of my issue comes from us starting and stopping SVO files (for some reason we can’t record more than a 3-5 minute SVO file without crashing our python Application). I don’t know if you’re doing a similar thing.

Just thought I would echo your issue in case it raises the response from Stereolabs.

Hi, I have been in contact with customer support and they admitted that this is their problem. It is a software issue so addressing it shouldn’t be hard hopefully. Is there any drift in the horizontal x,y axis? how much is it from your point of view?

There is some drift in X and Y (horizontal) certainly, but not as bad as the Z (vertical) drift, I haven’t quantified it though.

We’re still evaluating, and I got a similar response from Stereolabs, it’s good theyr’e working on it but yeah makes it pretty unsuitable for our purposes until we get that sorted.

Hi,

I also found this problem when using zed 2i. When I turn on ZEDfu’s offline mode, there is a very large drift in the Y direction (UP and Down direction). When I turn offline mode, this problem seems to be improved very well. But this should work in the opposite way.

Hopefully we’ll hear back from Stereolabs soon.

Hi,
How do you turn on and off ZEDfu’s offline mode? I am coding using the python SDK. Any settings for that? many thanks

Hi,

You can refer to this post ZEDfu:Turn on OffLine leads to poor performance.

The offline mode is avaliable in the ZED tools (ZEDfu). But I’m not sure how to code with the python SDK to turn on or off the offline mode.

Hope this information is useful.

Hi Mrassi,

Have you figured it out yet?