How to run zed_obj_det_sub_tutorial?

Hi, my setup is Jetson AGX Orin (ROS Noetic and JetPack 5.1.1) with ZED 2i camera.

I installed zed-ros-wrapper and zed-ros-examples and I am following the tutorial object detection, when I run:

rosrun zed_obj_det_sub_tutorial zed_obj_det_sub objes:=/zed2i/zed_node/obj_det/objects

My terminal do nothing, have I missed something?

(I set object_detection to True in params/common.yaml)

Hi @dominik
did you enable Object Detection by modifying the common.yaml file or by calling the enable_object_detection service?
Read here.

Yes, I enabled it :slight_smile: , also I’ve built all the packages without any errors.

I just noticed that your launch line is wrong:
rosrun zed_obj_det_sub_tutorial zed_obj_det_sub objes:=/zed2i/zed_node/obj_det/objects
it should be
rosrun zed_obj_det_sub_tutorial zed_obj_det_sub objects:=/zed2i/zed_node/obj_det/objects

There’s a typo in the documentation, I’m going to fix it immediately

1 Like

Works! Thank you. By the way, do you know why it detects only one person at a time? Is just wrapper limitation or can I enabled multi-person detection in some configs?

It’s a bug. There is a PR that fixed it. I’m checking it just now and merge it if it works as expected

The fix has been merged:

Please git pull to update.

1 Like