Crash when using Unreal Engine ZEDSamples

I’m starting to experiment with the ZED 2 and Unreal Engine but I get an Unreal Engine crash with the dialog error “GPU Crashed or D3D Device Removed.” when running the sample levels.

For example, when running the level L_BodyTrackingSingle and then reviewing the generated log, I see the following line, which seems to be the actual problem:

[2023.05.20-22.42.30:347][716]SlCameraProxy: Error: Can't enable BodyTracking: "EC_CorruptedSDKInstallation"

Tracing that error code in the source, I see this:

case sl::ERROR_CODE::CORRUPTED_SDK_INSTALLATION: /**< The SDK wasn't able to load its dependencies or somes assets are missing, the installer should be launched. */
					return ESlErrorCode::EC_CorruptedSDKInstallation;

But when I run the ZED Diagnostic tool, it shows no installation errors.

Has anyone else encountered this problem?

I’m running

  • Windows 10 (22H2) [10.0.19045.2965]
  • Visual Studio 2022
  • Unreal Engine 5.1.1-23901901+++UE5+Release-5.1
  • CUDA 12.1.105
  • ZED SDK 4.0.3

All AI models have been optimized.

Here are the diagnostics and logs
ZED_Diagnostic_Results.json (16.3 KB)
ZEDSamples.log (426.2 KB)


Following up on this, reverting back to CUDA 11.8 and the matching ZED 4.0.3 SDK solves this problem.

Hi @steved,

Maybe it’s a recently reported CUDA 12.1 path issue.
It seems that the UE5 plugin looks for CUDA 12.1 in the wrong path, we’ll fix this soon.

Did the ZED Tools / samples run correctly? ZED Depth Viewer for instance.


I’m actually the same person that reported the CUDA 12.1 path problem. I discovered that when working to get the ZEDSamples to compile. Interestingly the precompiled tools/samples do run correctly with CUDA 12.1.

I’m unblocked now that I’ve moved back to CUDA 11.8, but I’m happy to try something on my end with 12.1 if you have suggestions.

I tried quickly installing CUDA 12.1, and it seems that at least after a restart, it sets the variable CUDA_PATH too (along with the others)


I also had no trouble building, rebuilding or running the ZEDSamples project after the installation of the 12.1.

So yeah, not really sure why it happened. Basic question, but did you restart your computer after your 12.1 installation?

I’m pretty sure I rebooted after installing 12.1, but I’m not 100%. One thing I did notice is that when I downgraded to CUDA 11.8, that installer set both CUDA_PATH and CUDA_PATH_V11_8. I wonder if the CUDA installer only sets the general CUDA_PATH variable if it already exists?

I’ll try to find some time in the next day or so to go through the install process again and see if I can figure out what went wrong.

1 Like