ZEDPawn rotates but camera always faces towards 0 degrees when project is run

Hi all, thanks in advance for any help on this. I have read through the docs but I cant work out what is going on.

I am setting up camera tracaking in unreal…

If I place a ZEDPawn in unreal then run the project everything works as expected. If I rorate the zedpawn the rotation is not taken into account when I run the script… It always faces 0 degrees to start with even in the demo project if I place a pawn there.

I have tried changing the rotation of the Camera inside the zedpawn and this favces the correct wayto start but this causes the orientation of the tracking to be out by the same number of degrees!

all help apreicated



If you want to apply an initial rotation to the ZED Camera, you can do it in the ZEDInitializer object, in “Tracking parameters”. You might also need to uncheck the “set floor as origin” option.

Benjamin Vallon

Stereolabs Support

Thanks, sadly this is having no effect either, what am I missing?

edit: I have tried changing X Y and Z rotation in the tracking parameters in the zedinit but the zedpawn cine camera always just faces 0, I have set floor as origin off


Are you testing with one of the existing levels or did you create one?

Stereolabs Support

This happens in L_CameraTracking and also another level I created in the same project.

Aha! it IS working in L_CameraTracking but not another level where I have dragged in the INIT and the pawn. what am I missing? Thanks

Can you compare the params set in the ZED_initializer from the CameraTracking level and yours and see if there is a difference ?

It works! Not sure what has changed but that is now working as it should : )

Thanks so much for you help!

I have another quick question if you would be so kind. Is it possible to make the camera tracking active without playing the level?


No that’s not possible.
Can I ask you why you need this feature ?

I am in the early stages of setting up a macro virtual production rig and jumping in and out of play all the time is a bit time consuming that is all! Thanks for the info.

Is it possible to pilot the camera at the same time as having the tracking active? I have tried to toggle freeze and then pilot the camera but it doesn’t move once the tracker is active, only before I press play

What exactly do you mean by “pilot the camera”? With the tracking enabled, the virtual camera moves with the ZED Camera.

Stereolabs Support

I mean cntrl shift p - adjust the location of the camera in unreal using a gamer controller while in the play mode with tracking running. is there a way to adjust the camera location after freezing without dragging the numbers in the transform window?

thanks again for your help I am aware this is pretty basic stuff I am getting my head aroiund

Ta, Al.


Actually there is!

When the scene is running :

  • Freeze the camera
  • Right-click the Pawn in the hierarchy and click “Pilot ZEDPawn”.
  • Once the piloting is started, detach from the player controller (F8 key) and you can use the mouse and keyboard arrows (full list of the controls here) to move the camera where you need it to be.
  • Unfreeze your camera, stop piloting and attach to the player controller (F8 again) in the order of your choice, and the ZEDPawn view will jump there.

I’m not sure there is an out-of-the-box way to pilot the viewport via a gamepad, though.


This is awesome thanks for the tip Jean-Loup, I will give this a try when I am next at my machine