ZEDLiveLink Mono with SVO file

As I do not have an actual camera yet, I wanted to experiment with the ZEDLiveLink.exe (mono) to send LiveLink data to UE 5.3.2. I am running Windows 11 Pro. I have the latest ZED SDK v4.0.8 installed on my C drive (ProgramFiles(X86)) as per the installed. CUDA is also installed. I downloaded the zed-live link-main from GitHub and am trying the ZEDLiveLink.exe in the Releases->win64 folder. I have modified the ZEDLiveLinkConfig.json file…

“input”: “SVO_FILE”,
“input_path”: “ZED2_HD2K_Runners_H264.svo”,
“resolution”: “HD720”,
“fps”: 30,
“depth_mode”: “ULTRA”,
“grab_compute_capping_fps”: 0,
“enable_image_validity_check”: false,
“svo_real_time_mode”: true,
“sdk_verbose”: 0
“enable_pose_smoothing” : true,
“enable_area_memory”: false
“enable_module”: true,
“detection_model”: “HUMAN_BODY_ACCURATE”,
“body_format”: “BODY_38”,
“body_selection”: “FULL”,
“confidence”: 50,
“max_range”: -1,
“minimum_keypoints_threshold” : -1,
“skeleton_smoothing”: 0.2

I am using an example Stereolabs SVO file and it is currently in the same folder as the ZEDLiveLink.exe. I have tried the file in several location specifying the full path with using both / and \ as path separators.

When I run the ZEDLiveLink.exe, it get output in Powershell that it is loading the config file and then lists the settings, but then just exits back to the command prompt.

Am I missing something to playback an SVO file over LiveLink ?
Thanks for your help.



Can you replace “SVO_FILE” with “SVO” and try again?

If it still does not work, can you try using a USB camera to make sure the problem is not from somewhere else?


Best regards,

R&D Engineer
Stereolabs Support

Hi Jean-Loup,

Many thanks for your response. Changing SVO_FILE to simply SVO fixed this issue.
Thank you for your help.