ZEDfu stuck in RESEARCH mode after loosing the SLAM


I’ve tried to map outdoor using my brand new ZED 2i.
Spatial mapping goes well but the tracking state goes from OK to SEARCHING mode after a while, leaving an useless and unfinished map.
Resolution was set to LOW, range to FAR and depth mode went between PERFORMANCE and NEURAL (without any further progress).
The terrain is not easy (leaves, flares, etc.) but the IMU tracking is correct.
I’ve tested both on live and with a SVO file. I got the same results…
I’ve also tried to split the SVO removing the parts with some flares. It can recover some parts but we are far from the advertisements :slightly_frowning_face:

Is there a way to fix it ?
Hardware is Jetson Xavier NX.

Best regards

Indeed the spatial mapping will be paused if the positional tracking is lost.
Currently ZEDfu does not allows you to disable this behavior, you should use the spatial mapping sample and change the positional tracking parameter to disable the enable_area_memory.
Warning: by doing so, the positional tracking may drift but it will continue to output a pose and so the spatial mapping will remain active.

ZEDfu is just a fancy UI on top of the ZED SDK, it does not have more functionalities than the ones given by the SDK.

Thanks, seems to fix the issue.
Do you know if the ZEDfu UI will be released open source in the future ?
Or do you plan to add an option in ZEDfu to disable area memory (Would be greatly appreciated) ?

Yes, an option will be added in a future release.