ZED2i: zed_wrapper_node has died after searching for a known position


I launched the zed_wrapper_node with a saved memory area. After the node started, it was trying to relocate itself, and successfully found its location.

Positional tracking -> Searching for a known position [SEARCHING]
Odometry aligned to last tracking pose
Positional tracking -> OK [OK]

However, when I move the camera from its current location, it lost the positional tracking and tried to relocate again. But this time, the error happened as below:

Positional tracking -> Searching for a known position [SEARCHING]
addVertex: FATAL, a vertex with ID xxx has already been registered with this graph
bool slg2o::OptimizableGraph::Edge::resolveParameters(): edge not registered with a graph
addEdge: FATAL, cannot resolve parameters for edge 0x7f.....

The above error keeps happened 3 times before it died.

============REQUIRED process [zed2i/zed_node-3] has died!
Initiating shutdown!

I tried to find the log file of this error in the ROS log folder (as shown in the terminal) but couldn’t find it. Other node log files were still there, but no ZED log was found.

Can anyone tell me what happened with the zed_wrapper_node? and how can I prevent it in the future?

Thank you for your help.

Hi @luongqh
what is the version of the ZED SDK that you are using with the ZED ROS Wrapper?

Hi, I’m sorry for not mentioning the version.
I’m using ZED SDK 3.8.1 for L4T 32.7 (Jetpack 4.6.1) on a Jetson Xavier NX (Ubuntu 18.04 ROS Melodic).

Hi @luongqh
can you please share the AREA MEMORY file that you are using and record an SVO with ZED Explorer in the same environment?
This could be useful for the ZED SDK team to replicate your working condition and try to reproduce the issue.