Zed X camera not detected

I am using NVIDIA Jetson AGX Orin Developer Kit and 2 ZED X cameras. I am currently using one ZED X with no problem. But when I tried to use them both together I am getting camera not detected error in code. I tried zed explorer can not see the second camera there too. We tried the cameras with different cables, there is no problem with the cables. Second one not displaying on Zed explorer

Hi @emrekocdemir
please turn off the Jetson, disconnect the working camera, and leave the other connected, then turn the device on.
When the boot is completed please run the command $ sudo ZED_Diagnostic --dmegs and send the dmesg.log file that it generates.

In the second camera the pin of the connector seems to be broken. How can I supply the connector? Can you send me ?

Please write an email to support@stereolabs.com and add a closer picture of the connector from different points of view to better show the problem.
We will verify if the problem is covered by warranty and eventually open an RMA.