ZED UE5.3 Plugin issues with default UE5 skeleton


I’m facing Two issues when I’m using ZED with default Manny Sample skeleton.
Github project comes with UE5 Manny Sample mesh and there is already set up IK, retargeter and everything else, it works fine, but if I try to set up that myself I’m running into issues.

I try to set up from scrach and also just swap IK rig in retargeter and results are same, for same reason hands are not working how they should work. (I’m using Manny sample from third person example).

In my video I show that if I use your example I can put hands by my said and they are fine, if I use Manny from UE5 third person example elbows are always bent for some reason.

Second Issue I have is, if I try not to use retargeted project just crashes.

Here are also my test project files:

In Folder “Manny” can find two maps:
L_Retarget - That showcase my retargeting issue
l_NORetarget - my test with non retargeting, I have mapped only hand bones, but I doubt that would be issue why it crashes.

I need to solve this since it gives issues with any character that’s been rigged to UE5 Manny. I can’t figure out what exactly if different for your Manny example. (UE5 many not zed Manny).

Hello @Freymox

Thanks for the project reproducing the issues, that’s very appreciated!

I think that the retargeting issue is caused by the assignment of non-existing retargeting chains and the use of the IK.
To fix the twists, please try setting all the “twisting chains” in the retargeter to none. In general, try only linking the chains that exist in the dropdown list with the same name (though I think “Head” pairs with “Neck”). You will have a lot of none, but that’s okay.
For the bent arms/legs, I think that’s due to the IK goals of the hands and feet. You can disable the IK in the retargeter (click the chains with an IK goal in the chains list and uncheck IK). By default, it’s true, so that virtual hands are in the same position as real hands.

In general, to check the retargeting, as you might have to adjust the chains a bit (clavicle bones may differ for example), you may want to:

  • download an animation from Mixamo like from this page, and download it while unchecking the skinning option (so, no skinning).
  • import it in your project with the “force X axis forward” and “convert to scene units” options, while selecting the “ZED_Manny” SKM in the top dropdown.

You can then play this animation in the retargeter, check if it’s okay, and adjust the chains if necessary.

I don’t have a definitive solution for the “No retarget”, as it is not something we support or encourage. It’s expecting specific bones in the code like the two ankles, that might be causing the crash.

I hope this helps!

Thanks for replay, I will test it out and get back to you.
Another question on this note, is there any good way to disable vertical (z) movement for character or improve “foot sticking”? I lot of times when I walk around character just randomly goes in air or goes under floor.

Hi @Freymox,

It seems that at some point something broke between the anim blueprint and the body tracking visualizer :thinking:

You should be able to disable the foot IK and the adjustment to the floor from the BP_BodyTracking_Visualizer:

However, it seems that this does nothing. I’ll log it and fix this as soon as possible. As a workaround, you can go to the ABP_ZED_Manny anim blueprint and “hard-set” the values like so:

Thanks for the report!

Also, to adjust these instead of disabling them, you can explore the ControlRig in the anim blueprint or the ZEDPose node, which is written in C++. You’d have to dig into the code a bit.

1 Like