ZED SDK for Python: Version clash - DLL load failed while importing sd - tried copying DLLs different python versions path nothing works

Dear all,

on a computer no longer available to us, the Python SDK worked nicely. On the new computer, it just does not. We always obtain that “DLL load failed while importing sl: The specified procedure could not be found.” error, no matter what advice on the net we follow.

Old configuration:

  • Windows 10
  • ZED SDK 3.8.2
  • CUDA 11.7
  • Python 3.10.9 (64 bit)

New configuration:

  • Windows 11
  • ZED SDK 4.0.1
  • CUDA 11.8
  • Python 3.10.11 (64 bit), tried 3.8.10 and 3.11.3 as well

This is what we have tried already:

  • Different Python versions → always the same error message
  • Copying the DLLs to site-library → same error message
  • Copying the DLLs to site-library\pyzed → same error message
  • Adding site-library\pyzed\ to %PATH% → same error message

Instead of randomly trying new combinations of hacks and versions of any of the four elements of the software stack, it would be great to know the parameter which moves the needle.

Do we need to downgrade ZED SDK to 3.8.2 or upgrade to 4.0.3 (and CUDA accordingly)? Do we need to downgrade Windows? Do we need to try even more Python versions? Is the combo Windows 10 / ZED SDK 3.8.2 / CUDA 11.7 / Python 3.10.9 the only one which works (it would mean setting up the machine from scratch, and seeing that error message one more time thereafter wouldn’t really be good)?

Any advice beyond all our attempts is greatly appreciated.

Best regards,
Salomon

Hi,

From that link : python - ImportError: DLL load failed: The specified module could not be found - Stack Overflow
Can you run

dumpbin /dependents

It will help you find out what DLL the pyzed module is trying to find. Then, you can find out exactly which one it can find, which one it cannot.
Finally, you can add to your PATH the folder that is missing, or copy the DLLs into pyzed’s folder.

Please notice that python3.6 is less restrictive with DLLs, so you can start with that.
Also, in my experience the missing dll often is NvEncoreApi.dll :slight_smile:

Thank you very much. NvEncoreApi.dll is not one of the DLLs we’ve copied, and we’ll check with dumpbin if there are more missing DLLs :slight_smile:

Best,
Salomon