ZED-SDK Custom Detector Tutorial with Jetson Nano

Hi! I’m new to using the Jetson Nano, ZED-SDK, and Linux as a whole, so I’m a bit unfamiliar with a lot of things.

After installing the ZED-SDK and connecting a ZED 2i camera (works fine with the ZED Explorer) I went to try out the PyTorch_Yolov5 custom detector on their GitHub. Following the installation directions, the camera is initialized and a new screen pops up. Unfortunately, this screen is just black and the Jetson Nano struggles performance-wise as I can barely move the mouse and keyboard.

I was wondering if I could do anything to the detector.py code-wise (or anything else really) to at least get it working. There are no error messages that pop up in terminal and it’s just stuck on “Fusing Layers”. Feel free to request any info needed.

On the other note, these are things that I did before running the custom detector.

  1. I flashed Ubuntu 20.04 on a microSD and inserted into the Jetson Nano which is not supported. (GitHub - Qengineering/Jetson-Nano-Ubuntu-20-image: Jetson Nano with Ubuntu 20.04 image)

  2. When installing the ZED-SDK, I entered Y on all questions except for the Python API.

  3. Upon first running the tutorial, there was a fatal error that the file could not be found, I fixed this by changing all of the directory names to not have any spaces.

Hi,

Ubuntu 20 is not supported on Jetson Nano. Unless you are using Orin Nano?
Now, can you try to run a few tutorials, to be sure that your setup is running correctly ? Including the ‘standard’ object detection tutorial. Once it works, you can run the custom object detection examples, I advise you use the most recent one running yolov8.

Thanks for your reply, I’m currently using the Jetson Nano Developer kit (https://developer.nvidia.com/embedded/jetson-nano-developer-kit).

I tried the depth sensing, plane detection, and the image viewer tutorials. All of them worked fine, though the Jetson Nano threw a “System throttled due to over-current” issue, but the tutorials still worked fine.

Regarding Yolov8, it works fine, thanks for that suggestion. Although it is very slow fps-wise (the pop-up took roughly 5 minutes to load), I’ll have to see if I can disable certain unneeded features within the detector.py file. Yolov5, on the other hand, still pops out a black screen.