ZED ROS set_pose being overridden by IMU data?

Hi, I’m working on orienting a mesh obtained from by ZED 2 camera using an aruco marker. I get the camera → marker transformation and invert it to get the camera pose with the marker as my coordinate system center.

I’m using the zed-ros-wrapper’s set_pose service to set the camera pose relative to the aruco marker as the initial pose for my mesh. However, I notice that the rotation component is being overridden so that gravity always points down in the mesh. I’m assuming this is because the IMU is enabled and is overriding the rotation somehow?

How would I go about having the pose not be overridden here?

You may have already done this, but you definitely want to turn off auto-flip. I learned the hard way.