ZED Plugin for Unreal Engine 4.21 on Windows11 and NVidia RTX3060

Hello Everyone, Does anyone knows or try following environment, please let me know.

I have two ZED-mini environment (Windows10 with Geforce Titan, Windows11 with RTX3060).

(1) ZED mini, Windows10,
Unreal Engine 4.21-Zed, and plugin,
ZED-SDK3.0.3, CUDA 10.2
Oculus-Quest2 using Oculus-Link
==> No problem

(2) ZED mini, Windows11,
Unreal Engine 4.21-Zed and plugin,
ZED-SDK3.3.3 <== instead ZED-SDK3.01, shows “no gpu …” because RTX3060 not supported
CUDA 11.1
Oculus-Quest2 using Oculus-Link

To confirm examples work or not, I tried to use “PingPongMR” and “zed-unreal-examples”.
This examples can not be build (CUDA version check) as is, so I modified as shown below.

I succeeded build zed examples(also PingPong), Zed examples work fine on computer monitor, but On VR Mode(ALT+V) Oculus HMD shows BLACK screen.

I don’t know how to solve this problem, or UE4, Zed-mini will be supported for Win11 RTX3000 seriese?
Does anyone knows solution, please let me know.

best regards,


Modification 1: Stereolabs.Build.cs
public class Stereolabs : ModuleRules
{
private string ModulePath
{
get { return ModuleDirectory; }
}

public Stereolabs(ReadOnlyTargetRules Target) : base(Target)
{
    PrivatePCHHeaderFile = "Stereolabs/Public/Stereolabs.h";

    string CudaSDKPath = System.Environment.GetEnvironmentVariable("CUDA_PATH_V9_0", EnvironmentVariableTarget.Machine);
    if (!Directory.Exists(CudaSDKPath))
        CudaSDKPath = System.Environment.GetEnvironmentVariable("CUDA_PATH_V10_0", EnvironmentVariableTarget.Machine);
    if (!Directory.Exists(CudaSDKPath))
        CudaSDKPath = System.Environment.GetEnvironmentVariable("CUDA_PATH_V10_2", EnvironmentVariableTarget.Machine);
    if (!Directory.Exists(CudaSDKPath)) // ADDED!!!
        CudaSDKPath = System.Environment.GetEnvironmentVariable("CUDA_PATH_V11_1", EnvironmentVariableTarget.Machine);

Modification 2: Stereolabs.Build.cs
public void LoadZEDSDK(ReadOnlyTargetRules Target, string DirPath)
{
if (Target.Platform == UnrealTargetPlatform.Win64)
{
if(!Directory.Exists(DirPath))
{
string Err = string.Format(“ZED SDK missing”);
System.Console.WriteLine(Err);
throw new BuildException(Err);
}

        // Check SDK version
        string DefinesHeaderFilePath = Path.Combine(DirPath, "include\\sl\\Camera.hpp");
        string Major = "3";
        string Minor = "3";

Hi,

For the moment, the ZED SDK is not compatible with Windows 11 because of some CUDA installation differences.

For the RTX3000 compatibility, you can use the unreal plugin v3.5 (available here : GitHub - stereolabs/zed-unreal-plugin at UE4.21_ZedSdk3.5). You need the same ZED SDK version (v3.5.x) to make it work.

Best regards,
Benjamin Vallon

1 Like

Thanks Benjamin,
I deeply appreciate your kindness and advises.

I’d like to make sure how to install it.

  1. download ZED SDK 3.5.6 and intall it.
  2. download GitHub - stereolabs/zed-unreal-plugin at UE4.21_ZedSdk3.5

The next, I don’t know which way, I should do
3-1. I just copy (2.)'s plugin into UE4.21_zed which has already been built before.
→ UE4.21 can be started, and then some examples works, but no signal(black screen) on my oculus quest2.

or

3-2. Rebuild UE4.21_zed for ZedSdk3.5 again?
In my trial to build, There are many build error while build.

So, please teach me how to UE4.21 for ZED sdk 3.5.5?

best regards,

Hi,

You don’t need to re build the custom engine, you should just need to replace the plugin in your UE4 project and re build it.

You can also take a look at our documentation to see how to setup your project for VR/AR. It is available here : Build your first AR/MR App with Unreal | Stereolabs

Best regards,
Benjamin Vallon

1 Like

Hi Benjamin, Thanks reply,
I’m sorry my reply is late.

Actually, I tried my computing environment. Change Windows11 to 10 Professional 64bit.
Then, I installed and tried following steps as you said.

1.Unreal engine 4.21 zed
2.CUDA 11.0(ZED sdk 3.5.6 recommended)
3.ZED SDK 3.5.6
4.git clone UE4.21 for ZED3.5 and zed samples (including PingPong)
5.build and run

As the result, ZED examples show AR/MR on the PC screen correctly,
but in the VR mode or VR preview mode, My oculus quest2’s screen shows black screen.

Is this reason I’m using Oculus Quest2 instead of Oculus Rift ?
or Any special oculus UE4 project setting exists?

best regards,

Hi Benjamin, My Previous reply was wrong.
It just worked !!!

I mistaked that I cloned UE4.21 for ZED repository.
But I forgot to change the UE4.21 for ZED3.5 branch.

I appreciate your advise.

best regards,