ZED not detected with wrong serial number

When I launch the zed ROS wrapper nodelet (through the provided launch file), sometimes it cannot connect to ZED and prints on the console: ZED SN1108869120 not detected ! Please connect this ZED. The serial number printed is not the serial number of my camera and seems to be chosen randomly from a pool of a few serial numbers. This behavior seems to happen randomly and can happen/not happen in consecutive launches, without any changes.

How can I solve this problem and have a robust connection to the zed camera?

Thank you,

Hi Michele,
this behavior is normally present when there’s a not stable connection with the cameras.
Please check it.

If the problem persists please run the ZED Diagnostic tool and send the report file to support@stereolabs.com

Thank you for the immediate response.

The camera is connected directly through USB, I’m not using streming. Do you mean the physical connection could be not firm enough? Or something software-related could make it unstable?

Yes, check the USB port and the cable

The cable and port seem to fine. I have also tried to move the cable, usb plug and camera once the connection was established and I noticed no problem. It seems that once the connection is established, then it is stable.
I wonder whether I can be related to some non-physical issue.
The zed nodelet is running inside docker on a Jetson Xavier NX, mounted on the A203 V2 carrier board from seed studio. The camera is plugged in the USB of the carrier.
Also, is it expected that the serial number does not match the actual serial number of my camera? from dmesg the serial number read seem to be always fine.

@michele-colombo can you run the ZED Diagnostic tool and send the report file that it generates to support@stereolabs.com?
Please also cite this forum thread.

Hi, thank you, but in the meantime we solved by setting the serial number of our zed in the config file. Camera opening seems to be more reliable in this way.

Can you please provide more information on this solution?

We set the general/serial_number parameter inside zed-ros-wrapper/zed_wrapper/params/common.yaml file with the actual serial number of our zed. After that, we launched the zed node a few times, and we had no more problems in establishing connection.

This is indeed a good practice when you have a stable final robot configuration