ZED Multi Camera

I’m currently working with ZED SDK 3.4.0 and NVIDIA Jetson TX2; I connect two ZED2 cameras to a USB 3.0 hub (that is connected to the TX2) and run the multiple ZED Cameras sample (GitHub - stereolabs/zed-multi-camera: ZED SDK sample with multiple ZEDs).

The image streaming from the cameras are very intermittent; that is, if the sample is executed once, it streams images for a few seconds and then throws up the following message (which looks like some threading/bandwidth issue):

ZED_Multi_Camera: tpp.c:84: __pthread_tpp_change_priority: Assertion ‘new_prio == -1 || (new_prio >= fifo_min_prio && new_prio <= fifo_max_prio)’ failed. Aborted (core dumped).

In another seperate instance when I ran this program, I encountered the following message on the terminal after briefly streaming some images:

can’t claim interface 0: -6

At times, only one of the cameras is detected, and I need to unplug and replug them to execute the program; is there something I’m missing/I can do to fix these issues?

I have never tried using two cameras, so take this with a grain of salt, but I would suggest avoiding using zed sdk if you can. Just use the camera as a uvc compliant video source and pull the frames directly using cv::VideoCapture object.