Zed Hub No app.json manifest found

Hi, I am trying to use my bodytracking python code in zedhub. After zipping the file, I try to add it from the applications section, but I encounter this error. How do I add an application?


You zip file must respect a specific structure. You can run
edge_cli create_app python . to have an example of it, or find it in the documentation: Development Environment | Stereolabs

My project is based on https://github.com/stereolabs/zed-sdk/tree/master/body%20tracking/body%20tracking/python. so do i need to run this code in zedbox? and should i use this code like this? Should I use the code to cover the folder directly?edge_cli create_app python

I did the create_app part and uploaded the project but app giving me this error

It’s because the docker image you entered into the docker-compose file does not exist.
You can pick the one you need from here: Docker

You can also run the app without the docker packaging. For that, go on your device, and simply run the app. You can try that with tutorials: GitHub - stereolabs/zed-hub-examples: ZEDHub app tutorials

I am using NVIDIA jetson AGX orin developer kit. And I dont really know what to pick here I know my version is l4t35 but there is multiple choices for that build,runtime, devel which should i pick here ?

The minor L4T versio is important too. For example, for l4t 35.4, you can use the image stereolabs/iot:0.73.2-devel-jetson-l4t35.4-zed4.0

You can retrieve the L4T version by running cat /etc/nv_tegra_release in your terminal.

> # R35 (release), REVISION: 3.1, GCID: 32827747, BOARD: t186ref, EABI: aarch64, DATE: Sun Mar 19 15:19:21 UTC 2023 Should it be l4t35.3?

docker pull stereolabs/iot:0.73.2-build-jetson-l4t35.3-zed4.0
Tried this but still getting the error

this is the linux

and this is the hub

Your version is L4T35.3 indeed.
It’s not enough to pull the image. You must tell your application to use it. That happens in the docker-compose file of your platform, which would be docker-compose-l4t35.3.yml.

In the sample, that would be this file : https://github.com/stereolabs/zed-hub-examples/blob/main/samples/camera_viewer_sample/python/docker-compose.yml

If you want your app to be compatible with multiple platforms, check this one out: https://github.com/stereolabs/zed-hub-examples/tree/main/samples/multiplatform_sample/cpp

Did the docker edit now app running but now im not getting image

Apparently you solved it, can you explain how ? The community can benefit from your feedback

A different version was written in the BASE_IMAGE section you see here. I replaced it with the name of the file you downloaded by directing me in the middle parts of the topic. But as I said, the app shows running but I cannot get an image.

You wrote me in MP that it was running, I misunderstood. What are the logs ?

These are the logs. Stereolabs edge body tracking app is working but my app not displaying.

What happens if you stop this one and run our Camera Manager app?

Your apps working correctly and I can see the stream on hub.

Then the problem must come from your app. Can you share the code ?