ZED Depth Viewer crashes when openning ZED XM stream

I’m running a ZED XM camera on a Jetson AGX Xavier and streaming it to my PC. Both image and depth work fine in an app I made in C++ using the SDK. However, the ZED Depth Viewer crashes when I try to open the camera stream. I want to use it to compare performance with my application. Any suggestions?

I already tried this: https://support.stereolabs.com/hc/en-us/articles/8422008229143.

ZED_Diagnostic_Results.json (4.4 KB)

Hi @Mat198,

I apologize for the issues you are experiencing, this is not usual behavior.

Does ZED Depth Viewer produce any logs when crashing? Have you been able to use the streaming with another tool like ZED Explorer or with a C++ streaming sample?

Can you also share more details on how you are streaming the ZED X Mini data to your PC?


Hello @mattrouss,

I wasn’t able to reproduce the issue today. I remember that the Depth Viewer worked for the SVO playback but not for the stream. Now, it’s working for both. I’ll update this topic if it happens again.

Sorry for the trouble.

Hi @Mat198 ,

Glad to hear your problem is solved, let us know if this behavior happens again.

Hello, @mattrouss.

It happened again.

I’m streaming with the example provided by the SDK. I was able to use the stream with both my application and with the ZED Explorer.

I saved the logs this time.

Depth_Viewer_crash.log (4.2 KB)

Hi @Mat198,

In this instance you have uploaded an SVO file, is that right?
Do you have the same issue when uploading the SVO in other tools? If so, there may be an issue with the SVO, which you can try to fix using the tool:

ZED_SVO_Editor -repair /path/to/svo

Hi @mattrouss,

I had a Jetson AGX Xavier streaming the ZED XM camera directly. I opened the ZED Depth Viewer and as soon I entered the correct IP and Port to see the stream on my PC the Depth Viewer crashed. The stream recognized my computer IP.

Hi @Mat198,

Thank you for the report, we will investigate this issue further and get back to you when we can reproduce the issue.

1 Like

Hi @Mat198,

I apologize for the wait, we have tested on our end the stream for a ZED X Mini to an Ubuntu 22 PC and have unfortunately not been able to reproduce the issue.

What is surprising in you error logs that you have sent is that they suggest that the camera tries to open an SVO file, whereas you confirm that those errors were retrieved when opening a stream.
We are checking internally if there is some state issue in the application that makes ZED_Depth_Viewer crash like this.

To answer your initial tests, ZED_Depth Viewer uses the SDK internally to compute the depth information, so the official depth sample from our Github or your own application which only computes depth should have similar performance.

Hello @mattrouss,

Thanks for the feedback! I didn’t faced that issue recently.

Thanks for the confirmation that the performance should be equal.