Zed Box wifi not working

I’m new to using the Zed Box and recently purchased a model that includes Wi-Fi. However, I’m encountering an issue where the device doesn’t seem to recognize the Wi-Fi and Bluetooth adapter. I’m reaching out for assistance to understand the potential causes and solutions for this problem.

I have tried basic troubleshooting steps like restarting the device and checking the network settings. Additionally, I tried using the sudo modprobe iwlwifi command, which worked temporarily, but after rebooting the device, the issue returned and it stopped working again.


Did you flash your ZED Box ? There is a precise procedure for it, and if you don’t respect it you can miss Wifi. It is described here. Installing the ZED X driver (ZED SDK 4.0 - Download | Stereolabs) will allow you to get it back if you did not copy the right .dtb file during the flashing procedure.

I guess you can also add your command in a cron job that executes at reboot.

I have pretty much the same problem, except that for me adding the iwlwifi kernel module does not help. I did not flash the device.
After the first boot, the wifi worked fine but on consecutive attempts it does not. I also tried running the ZED SDK installation but it did not resolve the issue. I don‘t even see the adapters and not sure what I have to look for in dmesg. Can you give some more information on the hardware/driver that is used? Or will I have to flash/send back the device?

Thanks a lot!

Hi! tschut.

I’m not sure the problems are same. But I think my problem was caused by cable interference.

Because my box’s wifi worked well in some poses.
So I just opened my box and organized the cables.
Then wifi worked well in every pose.

I also flashed my box. But it was not the solution.

We had ordered a ZED Box a couple months ago and also found both the WiFi antennae were pinched by the case. While we did not test WiFi for functionality before or after remedying the cable management (since we do not use WiFi), it does point to a quality control issue with the ZED Box build specifically with the WiFi antennae.

My case is the same as yours. Has the issue been solved?