ZED 360 multi-camera calibration network workflow through ZED HUB not working

Dear Community,

I am now using ZED Hub to calibrate multiple ZED cameras connected to Jetson orin boards and cameras are installed in a common space.


  • Hub’s Camera Manager is now 0.1.4 version.
  • Orin’s board tegra # R35 (release), REVISION: 2.1
  • Nvidia jetson packages
    libnvidia-container0/stable,now 0.11.0+jetpack arm64 [installed,automatic]
    nvidia-jetpack-dev/stable,now 5.1-b147 arm64 [installed,automatic]
    nvidia-jetpack-runtime/stable,now 5.1-b147 arm64 [installed,automatic]
    nvidia-jetpack/stable,now 5.1-b147 arm64 [installed]

Step 1) When I add a new device, I run the script appearing on the portal but it exists quickly without any error and the installation was unsuccessful (no edge_cli installed).

Step 2) Then I download the script manually but the option -qO- does not download anything. Without the option, I find

ERROR: cannot verify hub.stereolabs.com’s certificate, issued by ‘CN=R3,O=Let’s Encrypt,C=US’:
Issued certificate not yet valid.
To connect to hub.stereolabs.com insecurely, use `–no-check-certificate’.

Step 3) Obviously I use --no-check-certificate option to download. After I get the file, I run it manually with this command output

Edge Agent 0.73.2 installer for mydevicename

Analysing operating system and platform

Downloading installer for Jetpack 5.1

Installing certificate

Running Edge Agent installer

but again this is unsuccessful.

Step 4) Then, I download the Edge_Agent_ script for Jetpack 5.1 manually. and again I need to use --no-check-certificate option. Finally, when I run the script, I find this error

Verifying archive integrity… 100% MD5 checksums are OK. All good.
Uncompressing ‘ZED IoT 0.73.2 SDK by Stereolabs’ 100%

Stereolabs Edge Agent v0.73.2 Installation.
Certificate detected in /etc/sl_iot_token.conf
Failed to retrieve access token, please verify your credentials at /etc/sl_iot_token.conf.

I already check /etc/sl_iot_token.conf to be installed successfully.

I would appreciate any assistance this community may kindly offer.

Thank you very much,


The last error is the simplest to fix - you are simply missing the sl_iot_token.conf that you can download from the same place where you found the Edge Installer.

As for the previous errors, I think everything comes from the certificate issue. I don’t reproduce this behavior. Does your device has an up-to-date clock ?

Last advice : ZED Hub is not mandatory to use the multicamera fusion, if that’s an issue for you. It’s just a lot easier to set up network cameras.