ZED 360 crashing


I wanted to implement multi camera fusion with two ZED X cameras. But ZED 360 crashes when two ZED X cameras are connected. It worked fine when only one X camera was connected. The software detects both of the cameras with auto discover but when I click “Setup the room” it loads for a second and then crashes. Any ideas how to fix this?

Edit: This is the output when I run ZED 360 from the terminal. I tried restarting the computer multiple times but this is always the same output. Other Zed Tools work fine for both cameras.

Running the fusion for 2 devices.
Setup ZED 42255191
 camera 42255191 failed to open
Setup ZED 48314490
 camera 48314490 failed to open
Unable to subscribe to 42255191 . MEMORY ALREADY USED
Unable to subscribe to 48314490 . MEMORY ALREADY USED
Segmentation fault (core dumped)


Hello, ZED 360 crashes because it is trying to run with 0 cameras. The initial problem (and the one that matters) is that ZED 360 was unable to open your ZED X cameras.

What kind of hardware are you using ? Does Depth Viewer works as expected with both cameras ?


I’m using NVIDIA® Jetson AGX Orin™ Developer Kit with GMSL2 Capture card for ZED X cameras - both were bought at the Stereolabs official store.

The Depth Viewer works as expected with both cameras. I have them both connected and I am able to switch between them in the Depth Viewer.

The ZED SDK 4.0.2 is online, your issue should be fixed

I will try it out! Thank you! :slight_smile: