Zed 2i camera port is not working

I have already installed zed sdk but when I run Zed Diagnostic, it is showing that it has a ‘Low USB bandwidth’ in device section.
And aslo, when I run a sample code in zed camera, it is showing,
‘freeglut (foo): ERROR: Internal error in function fgOpenWindow’.

how to solve this errors?

Hey @Chamodhieg , welcome to the forums!

This error can mostly because:

  • The camera is not plugged into a 3.0 USB port
  • There is an issue with the cable (not compatible with ZED, not correctly plugged)

Please attach the resulting file of ZED Diagnostic (Save button at the end of the process) if you want us to dig a little deeper.

Best regards,

Hi @Chamodhieg

Please use the “Save” button at the bottom of the window and share the file it will save.

Here, I have attached the Diagnostic results file. I couldn’t upload the file in Stereo labs forums because I am a new user.

I received it, thanks :+1:

  • Are you using an official ZED cable?
  • Can you try setting a higher power mode on your Xavier AGX?