ZED 2 Flickering in Unreal Engine Live link

I got my cam today. Ran calibration and nothing else.
I’m on 3.6.1sdk + cuda 11.
When adding ZED as Live Link source I have multiple animations spawning and getting deleted immediately. So does the avatar. It looks like missing frames or something.
I can’t see any errors in UE log except the occasional “Can’t evaluate frame xxx”.
The cmd ./ZedLiveLink says:

Opening camera...
[ZED][Init] Depth mode: ULTRA
[ZED][Init][Info] Camera successfully opened.
[ZED][Init][Info] Sensors FW version: 776
[ZED][Init][Info] Camera FW version: 1523
[ZED][Init] Video mode: HD1080@30
[ZED][Object Detection] [WARNING] sl::BODY_FORMAT::POSE_34 is chosen, Skeleton Tracking will automatically enable body fitting
Waiting for connection...
nb retrieved objects : 1

What I tried:
Switching USB ports.
Adding Binaries\Win64\ZEDLiveLink\ZEDLiveLink.exe as trusted app to my antivirus and firewall.

Please let me know if there is any other useful info I can provide (and how can I retrieve it)
Thanks a bunch!

Zed explorer shows a green window only. The Depth viewer works but is way more jittery than the one in the video Stereolabs ZED Camera - NVIDIA Jetson TK1 and Jetson TX1 Install and Demo - JetsonHacks


Thanks for your feedbacks.

I’ll do some tests on my side, but in the mean time, could you please :

  • tell me if you are using your camera in USB or you are streaming the camera from another computer.
  • try to run the body tracking cpp sample and see if the issue is still occurring. It will help me understand if the issue is coming from live link or your camera.

Benjamin Vallon

1 Like

Hi Benjamin,
Thank you for getting back to me this fast!

I’m using USB. Not streaming.

Here is the log from body tracking:

[ZED][Init] Depth mode: PERFORMANCE
[ZED][Init][Info] Camera successfully opened.
[ZED][Init][Info] Sensors FW version: 776
[ZED][Init][Info] Camera FW version: 1523
[ZED][Init] Video mode: HD720@60
Object Detection: Loading Module…
1 Person(s) detected

First Person attributes :
Confidence (86.4/100)
Tracking ID: 0 tracking state: TERMINATE / IDLE
3D position: 0.358 -0.158 1.14 Velocity: 0.232 0.0134 0.377
3D dimensions: 0.694 1.39 0.694
Keypoints 2D
Nose 826, -35
Neck 829, 92.9
R Shoulder 749, 108
R Elbow 685, 199
R Wrist 627, 282
L Shoulder 914, 77.4
L Elbow 938, 191
L Wrist 958, 293
R Hip 804, 317
R Knee 804, 477
R Ankle 804, 614
L Hip 887, 309
L Knee 881, 470
L Ankle 876, 607
R Eye 807, -40.6
L Eye 839, -47.4
R Ear 777, 2.92
L Ear 861, -13.4
Keypoints 3D
Nose 0.311, -0.734, 1.01
Neck 0.347, -0.543, 1.1
R Shoulder 0.189, -0.528, 1.13
R Elbow 0.0571, -0.346, 1.16
R Wrist -0.0697, -0.172, 1.19
L Shoulder 0.504, -0.558, 1.07
L Elbow 0.572, -0.346, 1.11
L Wrist 0.638, -0.143, 1.15
R Hip 0.319, -0.0926, 1.19
R Knee 0.317, 0.256, 1.18
R Ankle 0.322, 0.566, 1.2
L Hip 0.485, -0.107, 1.15
L Knee 0.484, 0.24, 1.18
L Ankle 0.483, 0.55, 1.2
R Eye 0.285, -0.771, 1.04
L Eye 0.343, -0.776, 1.03
R Ear 0.25, -0.757, 1.15
L Ear 0.417, -0.769, 1.12

Press ‘Enter’ to continue…

I recorded the video of depth viewer to better explain it.


Thanks for sharing the video.

The artefacts you see on the foreground of the video is caused by the small distance between the camera and your desk. The ZED2 camera requires a minimal distance to work properly which is completely normal for a stereo camera.

It can also impact negatively the body tracking module.

Benjamin Vallon

1 Like

Hey Benjamin,
Sorry it took me a while to get back to this issue. It still remains. I recorded the video from UE4. Maybe it can give you some hints. https://vimeo.com/manage/videos/645889007
I am ~4 meters away from camera. Ue4 cam is circling around me.

I tried reinstalling cuda 11.4, zed sdk, updating nvidia drivers, made sure ss usb3.0 port is being used.
Zed Explorer is still a green screen. Everything remains the same.

I am out of ideas.

Please, let me know if there is another troubleshooting path I can attempt.


It seems to come from the frame rate. For the moment, can you try to set the fps to 30 (and not 60).
I’ll look at this and update the repo once I have a fix.

Best regards,
Benjamin Vallon

1 Like

Hi again,

I pushed a fix. Can you test it and tell me if it’s good for you now ?

Best regards,
Benjamin Vallon

1 Like

Worked like a charm.

Much appreciated.

1 Like