Windows10 cuda 11 zed sdk 3.7 no PERMISSSION?

Well, that’s a day of my life im never getting back … please tell me how to fix this - ive tried so many versions and two different computers AND two different network providers … what gives ???

the only thing i can see different is that just before (when i tried sdk 3.5 with cuda 11 … it actually listed cuda 11 on the detection … whereas now ive changed to sdk 3.7 the cuda is not showing?? :S ) … however the zedfu and tools work which wouldnt happen without cuda

C:\Program Files (x86)\ZED SDK>python
→ Downloading to ‘C:\Program Files (x86)\ZED SDK’
Detected platform:
Python 3.10
→ Checking if exists and is available
→ Found ! Downloading python package into C:\Program Files (x86)\ZED SDK\pyzed-3.7-cp310-cp310-win_amd64.whl
→ Installing necessary dependencies
Requirement already satisfied: numpy in c:\users\rs\appdata\local\programs\python\python310\lib\site-packages (1.22.3)
Processing c:\program files (x86)\zed sdk\pyzed-3.7-cp310-cp310-win_amd64.whl
Collecting numpy>=1.13
Using cached numpy-1.22.3-cp310-cp310-win_amd64.whl (14.7 MB)
Collecting cython>=0.28
Using cached Cython-0.29.28-py2.py3-none-any.whl (983 kB)
Installing collected packages: numpy, cython, pyzed
Successfully installed cython-0.29.28 numpy-1.22.3 pyzed-3.7
Installing OpenGL dependencies required to run the samples
→ Downloading PyOpenGL-3.1.5-cp40-cp40-win_amd64.whl
Traceback (most recent call last):
File “C:\Program Files (x86)\ZED SDK\”, line 331, in
install_win_dep(“PyOpenGL”, py_vers)
File “C:\Program Files (x86)\ZED SDK\”, line 63, in install_win_dep
urllib.request.urlretrieve(whl_file_URL, whl_file)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 241, in urlretrieve
with contextlib.closing(urlopen(url, data)) as fp:
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 216, in urlopen
return, data, timeout)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 525, in open
response = meth(req, response)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 634, in http_response
response = self.parent.error(
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 557, in error
result = self._call_chain(*args)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 496, in _call_chain
result = func(*args)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 749, in http_error_302
return, timeout=req.timeout)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 525, in open
response = meth(req, response)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 634, in http_response
response = self.parent.error(
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 563, in error
return self._call_chain(*args)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 496, in _call_chain
result = func(*args)
File “C:\Users\RS\AppData\Local\Programs\Python\Python310\lib\urllib\”, line 643, in http_error_default
raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 403: Forbidden

C:\Program Files (x86)\ZED SDK>

I think it might be an issue with the file being in program files (x86).
I had a problem where I couldn’t install the whole thing because it was in the program files (x86), but once I moved the file outside of the program files (x86) and tried reinstalling, the installer fully finished without any errors.
I’m not sure if this is the same case, but hopefully it helps.

1 Like

sadly ive just tried this to no avail :S … good suggestion though thankyou

I’m sorry to state something that you might have tried already, but are you running your command prompt in admin mode?

Hey, were you able to solve this issue? I’m facing the same problem as well.

I just ran into this exact issue while using SDK v4.0 on Windows 10 with Cuda 11.3. I was working in a conda environment with python 3.11 and ran into the issue with pyopengl. I ended up uninstalling my python 3.11 within my conda environment and then running the install script again using my windows 10 downloaded python 3.10.6 and it worked without issue. I then downloaded 3.10.6 into my conda environment and ran the script using that python and it worked correctly again. I’m not if it’s just some strange version issue but that’s what worked for me. During my successful attempts I also didn’t run the “python -m pip install cython numpy opencv-python pyopengl” line that they list in the install guide first so that could have something to do with it.