Wi-Fi Not Working in Zed Box (Xavier-NX) with Jetpack 5.1.x

Hi everyone,

We recently upgraded the Jetpack from 4.6.1 to 5.1.x on our Xavier-NX. However, Wi-Fi is not working anymore on our device. We tested different dongles, but none worked. The main Wi-Fi dongle we were using with Jetpack 4.6.x that worked perfectly is a “tp-link AC600” dongle (Archer T2U | AC600 Wireless Dual Band USB Adapter | TP-Link Canada). I also installed the “rtl8812au” driver for it (just like what I did on Jetpack 4.6.x), but it’s still not working.

I’ve had this issue with both the Jetpack versions of 5.1.1 & 5.1.2.

Would be grateful if you could help me with this issue.

Thank you in advance

I don’t know about this specific device, sorry. Maybe you can have more luck with Jetpack 5.0.2 ?


Thanks for replying. We’re having the same issue with Jetpack 5.0.2 as well.

Can you try the ideas from this link? Trying to install drivers for a TP-LINK AC-600 USB Wireless adapter, failing - Jetson Nano - NVIDIA Developer Forums

Thank you for replying. Yes, I already tried it and didn’t work.
In 4.6.x, I didn’t need to install the wifi driver as it worked out of the box. But with the version 5, although I have tried several drivers/methods, it still doesn’t work.

For Jetpack 5, Nvidia upgraded ubuntu from 18.04 to 20.04. That’s a major thing. Probably your driver is not included anymore and you have to add it yourself. It’s probably easier to roll back to 4.6.x.