Video Recording Issues

Hello. I’ve been recording videos using the SDK 4.1.0 with the multi-recording exe, utilizing multiple ZED cameras at 720 resolution. The videos are slightly longer than 10 minutes, around 10 to 15 minutes. Even though I stopped the recording with Ctrl+C, some of the captured files are not working. They seem to contain data as the file sizes are not small. I tried using Repair; however, even though the program indicates that the repair was successful, the repaired files still fail to open. Could you provide information on what might be causing this issue or how I can retrieve the lost videos?

Hi @chklthepsps,

We have recently identified issues with the recording of SVO gen2 files and their repair.
Can you please run the ZED_Diagnostic tool and provide the resulting JSON file for us to have more information about your system and environment? This will help us troubleshoot more efficiently.

In the meantime, you can save your SVO files in version 1 using the following environment variable before running your program:
ZED_SDK_SVO_VERSION=1

Here is the JSON file. I hope you guys can suggest a solution for recovering the videos. I don’t want to lose the footage that I have.
ZED_Diagnostic_Results.json (20.2 KB)

Thank you for sharing the file, we are looking into this.

Can you please share the RecordingParameters that you are using? Are they the default ones in the sample?

Yes, we are using the default ZED_SVO_Recording_Multi.exe, just entering ‘4’ for 720p resolution. I tried another recording with one camera. After 45000 frames (almost 13 minutes), i stopped the recording, and it failed to open again. But if we stop it just before 13 minutes, it’s okay; the videos are working.

Hi @chklthepsps,

Thank you we have all the info to troubleshoot, we will get back to you once we find the source of the issue.