Unity Point cloud,

I have been using the point cloud renderer and the point cloud appears in the scene view and scene camera preview but not in any cameras in the game view. I have seen it work in the past but it seems like this might be something to do with the render pipeline I have tried in HDRP and in URP. My project is in HDRP. I am not sure what the issue is I have tried all sorts of things. it looks like it could be an issue with the point cloud material but if it was I cant believe that it would look correct in the scene view.

I am using unity 2021.3.12, the point cloud renderer is a separate object from the mono rig prefab.

I have gotten the URP test project I have to work to some extent but not the HDRP one

Any tips?


The point cloud is drawn in the OnRenderObject() callback which is not supported in HDRP, that’s why the point cloud was not visible in the Game View (it was not drawn at all).

I modified the script to make it HDRP-compatible. Replace your script by this one and it should be working.

Let me know if everything is working as you expect or not, so I can update the zed-unity repo with this update.

Benjamin Vallon

Stereolabs Support

ZEDFusedPointCloudRenderer.cs (9.0 KB)

I tried that, and it did not work. I did not have the fused point cloud renderer any where in my scene just the manager, I added the renderer to the main camera and also tried adding it on the same object as the cloud manager as well as its own game object with no results. looking at the comments in the script it should just work anywhere in the scene.

Edit: I got the fused renderer to work in a new project so that seems to be working, It does not refresh in realtime like the manager does however.
It looks like OnRenderObject was mis typed as onRenderObject. not sure if that was intentional.

I also see that OnRenderObject is in the point cloud manager is it possible there is an issue with that as well?