Tried installing ZED SDK on Jetson Orin NX with L4T 35.4.1 -- not found error

I had previously installed the ZED SDK on a Jetson Orin Nano running L4T 35.3.1 (Jetpack 5.1.1) and everything worked. Now I am trying to install it on an Orin NX running L4T 35.4.1 (Jetpack 5.1.2) and I’m getting the following error when I try to run ZED_Diagnostic:

ZED_Diagnostic: error while loading shared libraries: cannot open shared object file: No such file or directory

It seems exists on my Orin Nano, but not on the Orin NX running the latest L4T. I know that the SDK I downloaded was listed as being for Jetpack 5.1.1, but I thought it was worth a shot trying 5.1.2. I would rather not have to reflash my Jetson with an older Jetpack, just to run the ZED SDK. Are there plans to release a version of Jetpack 5.1.2 soon? Any way I could get it working right now with Jetpack 5.1.2?

Hi @pav
the ZED SDK does not yet support the Jetpack v5.1.2.
We will release a ZED SDK v4.0.7 patch version very soon that will support the new Jetpack.

Please write an email to in case you need immediate support for JP5.1.2

Thanks – I figured that was the case. I have gone back to JP5.1.1 for the time being.

1 Like