SVO to BAG crash while recording topics

Hello there,
I want to test some SLAM ROS algorithms playing back .svo file, to do it I need to convert the .svo to .bag file recording the required topics.
In doing it, I’ve tried launching:

roslaunch zed_wrapper zed2i.launch svo_file:="my-file-path.svo"

but also with:

roslaunch zed_display_rviz display_zed2i.launch svo_file:="my-file-path.svo"

and then, while the node is running, rosbag record.

For both the nodes, as I launch the rosbag record, they return messages like:

[ZED][WARNING] [Grab] CUDA error returned: invalid argument ( 1 )
CUDA error at /builds/sl/ZEDKit/lib/src/sl_core/utils/ code=1(cudaErrorInvalidValue) “cudaCreateTextureObject(tex, &resDesc, &texDesc, NULL)”

and in Rviz, the point cloud disappear.

I’ve tried lowering the fps to 0.5 but nothing solve it.

Furthermore, recording the topics from the .svo, are they all synchronized with a timestamp?

I’m using a Dell XPS 9570 with GeForce 1050 Ti, Ubuntu 20, Zed2i

Hi @umbnich
what version of the ZED SDK are you using and what ROS version?

I’m using ros noetic, zed sdk 3.8

Can you please send an email to attaching the report file generated by the ZED Diagnostic tool?

How can I generate the report?

Simply by calling this command:
$ ZED_Diagnostic
press the Start button and at the end of the process press the Save button.

From the report results I’ve CUDA 11.8 while I need CUDA 11.7 for the ZED SDK 3.8.

Now, I’ve downgraded CUDA at 11.7.

From nvcc --version:

Running ZED Diagnostics seems all green but doing the same stuffs of before I get:

CUDA error at /builds/sl/ZEDKit/lib/src/sl_core/utils/ code=1(cudaErrorInvalidValue) “cudaCreateTextureObject(tex, &resDesc, &texDesc, NULL)”

Can you try to play the SVO with ZED Explorer or ZED Depth Viewer to verify if the problem is present also by using the ZED tools?

The ZED tools work well. After downgrading CUDA from 11.8 to 11.7 the error is:

CUDA error at /builds/sl/ZEDKit/lib/src/sl_core/utils/ code=1(cudaErrorInvalidValue) “cudaCreateTextureObject(tex, &resDesc, &texDesc, NULL)”

every time I try to record with rosbag or when I move/switch a panel in Rviz.

Can you please send to the report file generated after downgrading to CUDA v11.7?

Here the ZED diagnostic report after downgrading to CUDA 11.7 (v 11.7.99 updated automatically).


Il giorno lun 14 nov 2022 alle ore 09:32 Walter Lucetti (Stereolabs) ha scritto:

Hi @umbnich
I cannot see anything in the Diagnostic report that explains your problem.

Can you share the SVO with us and post the rosbag command that you use for recording?
In this way, we can debug your issue by trying to replicate it.

Ok. I also have the problem with the grab_frame_rate. I’ve tried to lower the resolution and/or changing the grab_frame_rate but the issue persists.

rosbag record --split 1024 --size 2056 -O “/media/umbnich/TrekStor/Universita/2_Dataset/OpticsModule/Test Isola Capo Rizzuto 23-10-2022-20221027T104203Z-002/test” /zed2i/zed_node/left/image_rect_color /zed2i/zed_node/right/image_rect_color /zed2i/zed_node/imu/data

And I’m launching the .svo with:

roslaunch zed_display_rviz display_zed2i.launch svo_file:="/home/umbnich/Documents/ZED_umbnich/samples/umbnich/data/23-10-2022_17_54_22.svo"

Thank you

23-10-2022_17_54_22.svo (

Il giorno mar 15 nov 2022 alle ore 15:57 Walter Lucetti (Stereolabs) ha scritto:

I could replicate your problem on my device, we are investigating the causes because it happens only with the ZED ROS Wrapper and there is no reason this happens.

Is the problem present also by using other SVOs as an input?

Best regards,

Stereolabs Support

Hi @umbnich
the SDK Team already identified this issue and already fixed it.
The new SDK v3.8.2 that will be released very soon contains the patch to solve the problem.
I positively tested it with your SVO and I can confirm that after recompiling the ZED ROS Wrapper with ZED SDK v3.8.2 the problem disappears.
The simultaneous recording of data with rosbag was not the cause of the issue that was instead related to the retrieveImage API function used in a particular configuration.

Is there a way to upgrade the SDK without having to re-install all the other packages related? (I mean ROS etc.)

You do not need to re-install all the packages.
You install the new ZED SDK (when available), you delete the CMake cache (delete devel and build folders in the catkin workspace), and finally you recompile all the packages in the workspace with catkin_make -DCMAKE_BUILD_TYPE=Release.