Something's wrong with my Zed Mini IMU

There’s something wrong with my Zed Mini IMU, Could someone help me solve this problem?
When I didn’t move my Zed Mini, the Sensor Viewer detected that the camera kept spinning. And this happened at the same time in Unity.
(I’m sorry that I can’t upload the videos because I’m a new user.)
There is the video link:
Sadly, when I tried to update the IMU firmware through ZED Explorer, It showed that “Unable to read firmware File. File may be corrupted or wrong.”
Then how can I solve this problem?
By the way, I’m using the ZED SDK 3.4.2, and I also tried it in ZED SDK 3.1.

1 Like

This exact same problem just started happening for me! I’ve had my ZED sitting in the same spot for months, no interference. Just recently started using it again, installing all the software again for it and Unity on a new laptop, and it all of sudden is doing this weird counter-clockwise rotation when Tracking is activated

When you see the camera “spinning” in the “ZED Sensor Viewer” tool, that means that for some reason it lost the IMU calibration parameters.
You can easily restore the IMU calibration running the “ZED Calibration” tool from the command line, adding the flag --cimu or --calib_imu.
Before running the calibration process please be sure that the camera is completely steady and placed on a horizontal surface.
The re-calibration process is fast and fully automated, you can test if it worked correctly using the ZED Sensor Viewer tool.
In case it did not work please write an email to