Sl_ai library loading failed

I’ve installed the latest SDK_Windows_cuda11.8_v4.0.2 .
When I run the sample code for bodyTracking, the window is displayed, but Tracking is not done.
I also tried ZED360, but it did not track.
sl_ai64.dll is in C:\Program Files (x86)\ZED SDK\bin

Running Body Tracking sample … Press ‘q’ to quit
sl_ai library loading failed details: “sl_ai64.dll”: 指定されたプロシージャが見つかりません。
freeglut (foo): fgPlatformInitialize: CreateDC failed, Screen size info may be incorrect
This is quite likely caused by a bad ‘-display’ parameter


Can you send the output of ZED Diagnostics ?
Are you using a laptop with several GPUs, or a remote computer ? OpenGL seems not quite happy.
Also, did you install the AI module while installing the SDK ? It’s optional.


Hi alassagne.

When running ZED Diagnostics, the APP crashes when the ZED SDK check reaches 35%.
I re-installed the SDK but no improvement.

My laptop does indeed have two GPUs: an RTX4090 and an i9-13900H iGPU.
How can I solve the OpenGL problem?

The AI module is called optional, but I have never been asked when installing the SDK.
sl_ai64.dll was found in C:\Program Files (x86)\ZED SDK\bin

Your laptop is probably picking the wrong GPU when running the SDK. Can your force the usage of the other one through the nvidia configuration panel ?
Can you send ZED_Diagnostics from a terminal and send me the console output, until it crashes ?

I have set the nvidia control panel to prioritize the dGPU and reinstalled the SDK, but Diagonostic.exe still crashes.
I also tried to force the use of the dGPU in the laptop’s native App, but the result was the same.

I will send you a cmd log of Diagonostic.
log.txt (38 Bytes)

Your log is incomplete, I just have one line on it. Can I have the full thing, starting from the line that runs ZED Diagnostics ?

Sorry, cmd did not work.
I will send you the log.txt that came up using git bash.
log.txt (658 Bytes)

It does not say much unfortunately. Do you see any weird error when installing the SDK ?
Can you try the diag again without a camera plugged in, just in case ?

Finally, what if you run the body tracking sample while adding the solution from here in the beginning ? python - "CreateDC failed, Screen size info may be incorrect" - Stack Overflow

I’m not getting any errors with the SDK installation.
I ran ZED Diagnostic.exe without ZED connected, but it still crashes.
I also took a log, but it is the same as before.
log.txt (664 Bytes)

I followed the stackoverflow and it solved the problem caused by the display. Thank you.

Good news ! Does the body tracking work then?
It’s still weird that ZED Diagnostics crashes though

No, bodytracking did not work at this time.
However, all my problems were solved just now!

It was due to the system environment variable Azure Kinect Body Tracking SDK Path being above the ZED SDK Path.

C:\Program Files\Azure Kinect Body TrackingSDK\sdk\windows-desktop\amd64\release\bin

After rearranging the order of this Path, Diagnostic.exe worked!

Also, the BodyTracking sample code worked fine after the following log!

Running Body Tracking sample ... Press 'q' to quit
 Downloading skeleton_body18_3.2 100.0%[========================================] 94.7/94.7 MB Done
 Optimizing skeleton_body18_3.2 | 100.0%[=============================>] Done ! in 0min 46s
1 Like