Sending RTCM3 corrections to ZED Box with built-in ZED-F9P

Has anyone had trouble getting an RTK Fix on the ZED Box with the ZED-F9P GNSS receiver? I had to use pygpsclient and ubxtool to configure the module to output NMEA GGA messages for VRS and input RTCM3 corrections. I tried using str2str from RTKLIB to handle RTCM3 corrections but the most I can get (according to gpsd) is DGPS. Tried contacting u-blox but they refer me back to Stereolabs. This issue here describes almost exactly what I am experiencing:

Also, I know that the interfaces that come up on the system appear as ttyACM0, ttyUSB0, and ttyUSB1, but which interfaces on the F9P module do they correspond to? (ie: USB, UART1, UART2, SPI, etc.) Couldn’t find this anywhere in the documentation and sorta makes it a lot harder to troubleshoot.

Anyones help is greatly appreciated!

Hi ! Did you solve this? I am experiencing the same issue:
I couldn’t get RTK correction and contacted the RTK provider which shared the error they face:

Rover user ‘prospecto’ rejected. No GPGGA message received. Access denied.

Some RT Products require an NMEA GGA string sent by the rover user. The connection is closed by Spider if no NMEA GGA string is received within a specified time range.