RTX 3050Ti GPU not detected by Zed applications


I built a C++ application using the Zed SDK that worked as intended. Recently, when I tried to use it on a new Dell G15 laptop that has an integrated AMD Radeon GPU as well as a discrete RTX3050Ti GPU, the application fails to run.

Furthermore, ZedFu and Zed Depth Viewer indicate that a valid GPU wasn’t found. This is despite the fact Zed Diagnostics detects and lists the RTX 3050Ti. Even Zed Explorer is unable to record or playback h264 svo files.

Is there anyway to force the Zed to use the discrete GPU (apart from doing it in my code, since I still need the Zed tools to work). I think it somehow keeps reverting to the integrated AMD Radeon GPU.

I would appreciate any help with this!


Hi @shivak7
you did not add this info, but I suppose that you are under Linux.

Probably the system cannot automatically activate the Nvidia GPU when required.
You can use the command
$ sudo prime-select query
to understand your configuration. If the setting is on on-demand you can try to force nvidia with the command
$ sudo prime-select nvidia

In this way you should be able to start the ZED software.

Hi @Myzhar,

Thank you for the response. I apologize, I thought I added windows as a tag to the question.
It is a Windows 11 system actually, not Linux.

This computer also has no option of switching/disabling GPUs in the BIOS either, unfortunately.
Anything else I can do? Thanks!

@shivak7 I’m sorry, I did not notice the tag.
Can you please run the ZED Diagnostic tool and send the report file that it generates to support@stereolabs.com to open a support ticket?