Remote svo recording error

I am trying to stream and record in same time. And in linux terminal I am doing both of these. But when i try the run the code with ssh connection to linux , code perfectly opens stream and records the svo file. But while opening the svo file I saved with Linux, I get an invalid svo file error in the svo file I saved by connecting to the terminal via SSH. I am using the same code for both ways stream works for both and like i said SSH svo gives invalid svo file.

It’s probably related to the ctrl+C command. I can’t issue ctrl+c command in ssh client so I run this command on c#

string stopCommand = "pkill";
var command = client.RunCommand(stopCommand)

To stop the stream and save this works great, it closes and saves the svo file but still gets invalid svo file. I tried it in the Linux terminal, when I close the terminal to stop the project, the svo file becomes invalid, but when I close the project with ctrl+c, the svo file appears correctly.


I think you found the cause indeed. The SVO recorder could not write the last frame because it was forced to exit. However, you can repair your SVO afterwards with ZED_SVO_Editor -repair input.svo

In the latest ZED SDK version (from 4.0.7), the repair should be automatic. What version are you using ?

I am using 4.0.7 zed sdk version

Maybe the automatic repair is not working as it should. What about ZED SVO Editor ?
Can you send me one of your SVOs ?

Can you give me your mail adress? Also I cant open zed svo editor too but I found a way to send ctrl+c via ssh