QGLShader::link: "error: linking with uncompiled/unspecialized

Hi, I keep having the following error after I run ZED_Depth_viewer:
QGLShader::link: "error: linking with uncompiled/unspecialized
i tried uninstalling CUDA and reinstalling ZED_SDK with CUDA I still get the same error.

I read from the Forum I can try:
prime-select nvidia
But when I do this, my laptop just freeze after reboot. Have tried many ways without luck.
My system is with RTX 3080Ti and I have installed the latest nvidia-515
Any suggestion how to proceed.

Hi @lqfjun88
can you verify if you have the secure boot enabled in the BIOS configuration.
It is the cause of many problems with the Nvidia drivers.

Hi @Myzhar
Thks for the quick reply
Yes, I have double confirmed it is disabled secure boot

I suppose that the problem is with Ubuntu, right?

BTW, I can run pytorch with cuda running with no error

So I must do this for ZED to work?

prime-select nvidia

Yes, sometimes that’s the good solution for this kind of problem

Finally found the solution. I just need to upgrade the kernel so that the following command will not hang when boot:
sudo prime-select nvidia

For pple who are interested to upgrade kernel, here is what i do:
sudo add-apt-repository ppa:damentz/liquorix && sudo apt-get update
sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

1 Like