Pyzed .whl download not working - URL Not Found - SDK 3.6

I am following the instructions to download the pyzed python package for my Windows system on ZED SDK 3.6. I am running Windows 10 with CUDA version 11.1.

In the ‘’ script, it is failing to retrieve the pyzed .whl file because it says “URL Not Found”. It is trying to retrieve from this link: “”. When I paste the link in Microsoft Edge, it directs me to a 404 Not Found.

However, when I try with SDK 3.4, the given URL the script provides works correctly and I am able to download the .whl file (when I paste that link into the website it is able to download the .whl file as well). But I am unable to use SDK 3.4 with my new ZED 2i camera. Whenever I load up ZED 2i, it is never able to produce any output when I run a python script using the pyzed module and when I run the example executables that were given with the SDK download. The camera only seems to work with SDK 3.6 (I am able to run “ZED Depth Viewer” and other programs and see the camera output).

I am currently unable to get pyzed module downloaded with SDK 3.6. Can someone please provide an updated link for the .whl file or let me know why its not working. I am unable to get it working with SDK 3.4 either because although the .whl file is downloading, my camera itself refuses to work with SDK 3.4.

I would appreciate any help on this. Thanks!

Hi, other users had the issue a few days ago Invalid URL for python API whl download · Issue #204 · stereolabs/zed-python-api · GitHub
It should now be resolved.
Sorry for the inconvenience

As a backup, the source code is hosted on GitHub and can be compiled zed-python-api/src at master · stereolabs/zed-python-api · GitHub